Bug tracker and PTP feature request

tried to submit a bug, but got “Oops! That page doesn’t exist or is private.” when following a link to the bugtracker.

my problem is the following: I would like to used PTP to do image capture:

meta@gentx ~ $ gphoto2 --summary
Camera summary:                                                                
Manufacturer: Fairphone
Model: FP4
  Version: 1.0
  Serial Number: 301E400F28FBC091A54078xxxxxxxxxx

Capture Formats: 
Display Formats: Undefined Type, Association/Directory, Text, HTML, MS Wave, MP3, MPEG, JPEG, TIFF EP, BMP, GIF, JFIF, PNG, TIFF, Unknown(b901), Unknown(b902), Unknown(b903), Unknown(b982), Unknown(b983), Unknown(b984), Unknown(ba05), Unknown(ba10), Unknown(ba11), Unknown(ba14), Unknown(ba82), Unknown(b906), DNG, Unknown(3812)

Device Capabilities:
	File Download, File Deletion, File Upload
	No Image Capture, No Open Capture, No vendor specific capture

Storage Devices Summary:
store_00010001:
	StorageDescription: Internal shared storage
	VolumeLabel: 
	Storage Type: Builtin RAM
	Filesystemtype: Generic Hierarchical
	Access Capability: Read-Write
	Maximum Capability: 110382735360 (105269 MB)
	Free Space (Bytes): 101108068352 (96424 MB)
	Free Space (Images): 1073741824

Device Property Summary:
Property 0xd401:(readwrite) (type=0xffff) 'Fairphone 4 5G'
Property 0xd402:(readwrite) (type=0xffff) 'Fairphone 4 5G'
Image Size(0x5003):(read only) (type=0xffff) '2340x2340'
Battery Level(0x5001):(read only) (type=0x2) Range [0 - 100, step 1] value: 74% (74)
Property 0xd407:(read only) (type=0x6) 3

will this ever be implemented?

As this is no official support here and a public bug tracker only exist for the FP2 you might need to #contactsupport to adress this

Edit: maybe you can elaborate a bit what you try to achieve or what is not working, because I can select PTP for picture transfer to my PC?

I don’t just want picture transfer.

I want my computer to be able to use the phone as a camera, ie. I want my computer to be able to press the “take photo” or “take video” without having to build a mechanical finger (and attaching another camera - which I don’t have, that’s precisely the point - to have a feedback loop in order to make sure everything works smoothly

Does any Android phone actually support this? Anyway, in the meantime you can use something like IP Webcam. It works over Wi-Fi, as well as over USB tethering (192.168.42.129:8080).

2 Likes

There are many touted options

Have you tried any

https://www.makeuseof.com/tag/can-i-control-a-phone-with-my-computer-android/

1 Like

didn’t think of using an app… it’s just very annoying that one buys a phone, then either has to survive all the adds or pay more to get access to features that really should be included and either way risk installing malware

not quite “fair”, IMHO.

thanks for the tip.

unfortunately this is pretty much useless for someone who wants/needs to script stuff

1 Like

But that’s how smartphones work, installing apps for a purpose. Not everything is implemented in the firmware.

That’s why I asked you if any Android phone actually supports this feature. Because until now I haven’t really heard of it. You can definitely #contactsupport and make an official feature request. But I honestly doubt they will give it a high priority.

3 Likes

You obviously have little knowledge about how electronics and computers work ; the operating system is technically not the firmware. The “camera” is already an app that is installed by default in the OS.

You are right, I have little knowledge about computers, it’s only my bread and butter.

Anyway, if it’s already an app, why not use a different one?

Find some apps that does not require payment and that have the same functionality as the packaged app. Test it, then once you’ve found something that is suitable let me know. Also tell me how much time you will have spent doing this.

As an alternative, clone the source code of the packaged app, add a few lines of code to have the new feature, make a pull request.

But oh… the source code is not available. And the phone is not rooted, so it might not even be possible to remove the camera app (risk of “bricking” the phone, they say).

The problem is political more than technical.

Why should I do your work? Find yourself an app, that fulfills your requirements. You don’t have to delete the original camera app.

Why do you expect gphoto2 to work with a phone in that way? Have you had a look at their documentation? There are only proper cameras listed as supported with remote control.

You can use something along the lines of …

adb shell 'am start -a android.media.action.IMAGE_CAPTURE && input keyevent CAMERA'

… to take pictures, you’ll obviously have to refine that further, have fun with that.

Use scrcpy if you need a visual component for that or want to use your phone’s screen as a webcam in Linux.

This is a user forum, none of us get paid to help you, so good luck, I’m out :mute:

3 Likes

now that was actually useful. unfortunately my phone is not recognized by adb on my desktop.

thank you.

Correct phone status while trying adb access?
Windows or Linux Desktop?
USB data, cable? Other cables? Other USB port?
Driver update on desktop available?
Sudo access on Linux?

1 Like

this is getting off-topic a little… anyway:

Correct phone status while trying adb access?

yep

Windows or Linux Desktop?

GNU Linux (I don’t have a recent Windows machine to test). OS is Gentoo 2.9 with default/linux/amd64/17.1/desktop profile.

USB data, cable? Other cables? Other USB port?

cable is fine, USB ports are fine.

on laptop only adb works (not fastboot). on desktop, none work. lsusb shows the phone in all cases. gphoto2 gets correct phone status on desktop (untested on laptop). android-file-transfer fails on desktop (was OK with my previous phone), succeeds on laptop

Driver update on desktop available?

android-tools dist version is 33.0.3-r1, same on both my machines.
Android Debug Bridge version 1.0.41

Sudo access on Linux?

tried as a user, and as root. have been using Linux for almost two decades, and have passed LPI/101/102, I am pretty sure my user permissions are correct.

Just to be sure.

When you connect your phone to the computer, you have to set the phone to “File transfer” or something else by swiping down from the top and tapping the “Charging” notification. Then you can change the connection mode from “Charging” to “File transfer" or something else.

And if your desktop still doesn’t see your phone, then it could be that the permission isn’t good.
So revoke USB debugging authorisations in the Developer options.

you have to set the phone to “File transfer” or something else

yes

So revoke USB debugging authorisations in the Developer options.

I tried toggling these options on and off. Early in the trials, I had the strange issue of having to enable developer mode twice (I even have a witness to this who is a computer engineer)

Yes there’s often a request to disble it after each use.