[Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

This is a #wiki post. Feel free to edit it clicking on the green pencil :pencil2: above

Since a lot of people is suffering this (I stopped counting at 14 persons five days ago) and messages are scattered all over the forum and making a mess of the official release thread, I’ll try to link useful responses here, for reference.

You don’t need to install any particular app (UnifiedNLP, microG) or mod (tingle, Xposed) to suffer the bug.
BACKUP YOUR SYSTEM WITH TWRP BEFORE UPDATING, if you have not update yet, or backup before each update from now if you suffered this. That’s how some of us saved our data.

Bug Description

After applying 17.06.4 update, whether from Fairphone Update or from the OTA flashable ZIP, and waiting for the apps optimizations on the first boot, phone freezes when trying to unlock the screen or after entering the PIN and it reboots. This situation happens again for every reboot.

Official bugtracker report



Same behaviour was observed in beta 1, 2 and 3 (all beta versions) of Fairphone Open 17.06.* by @Roboe, @tukss, @freibadschwimmer and @lklaus:


(You couldn’t be able to access the above thread if you’re not part of the beta testers team)

First public announce

Possible workarounds

Make a TWRP backup of the broken system just in case you lost SMS and contacts, so you can restore them later

Preserve all apps, but system settings and app’s data are wiped:

Preserve all system settings and data, but app’s data are wiped:

Download links for different releases

Restore lost contacts and SMS after restoring system

Some people experiment contact lost apart from the broken update. Here is a method


Hello there,

this morning i installed the latest Fairphone Open Update (17.06.4) via the Updater.
Unfortunately i didn’t notice, that this is Android 6-based.
Needless to say i didn’t upgrade to Android 6 before.
And, stupidly, i don’t have any backup (yes, shame on me).

Now my phone gets stuck after booting. I can enter my PIN sometimes, but after that, there’s no respond to any touch or button.
Occasionally, the phone falls back to its start-screen (Fairphone […] with the blue dots moving).
Back to the normal screen it is then stuck again.

It works in Safe Mode!
But i don’t know, how to identify the faulty app or system-part.
I think it must be some basic-part of the OS, because the PIN-entry is sometimes impossible, so the faulty function seems to be started early in the process!?

Is there any possibility to revert to Andriod 5 (e.g. by manually flashing with the downloads from here: https://support.fairphone.com/hc/en-us/articles/213290023-Fairphone-OS-downloads-for-Fairphone-2)?

Further, is there a possibility to backup at least my contacts and SMS (e.g. with TWRP)?
Or even, a possibility to run Titanium Backup (which is installed) and even save my app-settings?
Maybe via the console?

Thanks in advance for any help.


1 Like

Check out this post:


Oh, i didn’t read that post entirely, because the first 10 posts were just news. My bad.

I will try what’s mentioned there later.
I’ve already backuped my (faulty) system with TWRP.
So at least i can go back to this error-stage, correct?

Thank you.


If the error is not in the data partition you can even use the backup once you got the system running again.

I’ve now done what the post suggested.

Now my phone is stuck in a cycle:
Android is starting - optimizing App xx of xx
Android is starting - starting App xx of xx
then the Fairphone-screen appears with “loading” flashing
and then it falls back to optimizing the Apps.

should i try what’s mentioned here?

It sounds like maba007 didn’t boot before updating to 17.04.6?!?

I have the same problem, and have turned off the phone by removing the battery to let the phone cool down. I’ve done this about 10 times so far, with no success yet.
Should I just keep doing what I’ve done so far? I didn’t back-up before turning off, and now I can’t do any #dic actions.

I guess you’re talking about the FP Open Marshmallow update. This thread was about a bug in regular FP OS Marshmallow which is already solved.

Go there to find others with the same bug (notified in the beta fase and ignored, BTW): Fairphone Open 17.06.4 (Android 6.0) release

I’m following instructions on how to do a hard reset but it still hasn’t got me out of bootloop. In fact, there is no option for '“Yes - delete all user data” in the action list. So, I’ve confirmed the wipe data, wipe cache partition and reboot system. I presume that for each of these actions it’s enough that the screen line turned green for the phone to have registered that action? Unfortunately, I’m still in the bootloop. Any more specific directions greatly appreciated!

I just updated and I cannot unlock the phone anymore, it always freezes and restarts when I try it. It freezes as soon as I swipe up or double-tap a message on the screen. It doesn’t even show the keypad. It also takes ages to unlock the SIM card.

First, thanks for this thread and redirecting me here.

“Luckily” the update had failed the first time I tried even before installing, so I got suspicious, read the forum and made a TWRP backup. I just now restored that backup and everything is how it was before. Any suggestions on how to proceed? Should I just wait for a newer update that fixes this bug or should I try to update by another method?

I just learned about TWRP and fastboot when reading the thread about this update and I’m not yet familiar with it ;-). It took me already some time searching the forums and Google to find out how to even boot to TWRP. Somehow I usually find it hard to find this kind of info on the forums.

1 Like

Same issue here.
I had FP Open OS 16.12.0 and tried a direct upgrade to 17.06.4, bad idea…
I first removed Xposed completely (flashing the uninstall zip), then proceeded using the updater app.

Upgrade went fine, but I had the 1st freeze on reboot after optimizing 103 apps.
I had one or two other apps optimizations, with a different number of apps (137 for the last), but now after each reboot I see the lock screen and it freezes there.

I had once the screen requesting PIN code, but froze immediately and never could enter it.

I restored my TWRP backup for now… I’ll try again by first upgrading to 17.04… :S

Thank you for your help.

Are there any reactions by the developers yet? I am wondering when it is safe to upgrade to Android 6. Waited for it eagerly, but your reports (also big thanks for sharing them) discourage me from doing it.

I have to say I am also quite frustrated…
Btw I successfully updated to 17.04 but same problem when trying to update to 17.06.
So the issue is for me at least from 16.12 and 17.04.

You having a backup makes me happy, :slight_smile:

None. They had not even accepted the bug in the bugtracker yet, 🤦

Yes, frustation is the word. I’m eager to switch to LineageOS once it becomes official.

Maybe because of the frustrating success in Lineage OS development… :wink:

Why? The Fairphone team doesn’t have anything to be with the LineageOS porting efforts.

I know. I have been thinking about frustrated Fairphone developers because Lineage OS does perform so well on the Fairphone 2. (Just laugh at me! :wink: )

FP Open should not be ditched, anyway. There’s a way in which FP Open could still shine over LineageOS, even on Marshmallow. I already talked about that on this other thread:

(Please reply on that other topic about the matter)

@Douwe told me in an official tweet that they will “fill in details later” about the bug:


After many unsuccessful attempts of updating to the Android 6 version of OpenOS (both beta and release version), I finally got it to work without wiping all my app data.

I used to get freezes just a few seconds after booting. The UI restarted about a minute after the freeze. I tried it again today with 17.06.4. Everything went smoothly this time. I didn’t loose any data. I think the difference was that I removed the app Wakelock Detector, which had a component installed as root, before the update. Do any of the people with the freeze problem have this app installed?

1 Like