Bug: I cannot install or update anything on my fairphone 4

Hi, I just recieved my phone today and i couldnt install anything on my phone on playstore only: I tried to
enable/disable play store, empty the cache files, changing my google account, and nothing works… So i tried to install some random apk and It worked ! But It doesnt seem to be a viable solution.
Any help?
Thks in advance
Eliot

Hi and welcome to the community, as you dont have much installed, I would first try a factory reset and start new from scratch.

And maybe if its still not working you can explain a bit more detailed what exactly happens?

1 Like

Hi, thank you for ur answer. I already tried a factory reset and I still cannot dowload or update any application. I forgot to mention something : the SP28.B.065 update of android cannot be made by my phone it is talking about internet issue but my internet work on the phone…

Mobile and/or WLAN? Anything blocking internet somehow? Netguard…

1 Like

I cannot use mobile to do the update and I tried two separate wifis

So if you havent installed something, that is somehow potentially blocking internet, no VPN or anything, maybe try to download the F-Droid Store and from there the Aurora Store and see what happens, with anonym account or your Google Account added.

So which OS Version is installed on your device? Because the one offered is not the most recent and where did you buy it?

1 Like

I bought it on faiphone.com, i dont have any vpn . I gonna try F-droid. I’m currently on android 12.

Ok i tried F-droid and it is working! But play store, still not :frowning:

This is my playstore version: 36.3.12-29 [0] [PR] 542033711

So have you tried to download the Aurora Store from F-Droid and install playstore Apps from there

1 Like

yeah and it is working, because it is using apk no?

So Google has its own support page maybe its worth it to check there as well…

Probleme beim Herunterladen von Apps aus dem Play Store beheben - Google Play-Hilfe

1 Like

Yeah i tried everything from this page. I also tried to re install the os, but for some reasons i didnt manage to unlock the bootloader . I think i’m just gonna send back the phone to the company

Did you try with aurora using anonymous and logged in option?
Did the Google play app ask for any permission (which you maybe denied)?
Have you inserted an SD card into the phone?

1 Like

And there might be a problem with your Google account?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.