Bootloop after too many notifications

Hey Guys!
I’m owning the “big” FP4 .
I’m having trouble with my Phone since last night. There was an App (nextcloud) which produced several 100 notifications per hour because of sync issues. I ignored that, wanted to handle that today evening.
Today morning, I oversleep, the alarm of the FP doesn’t ring. I watched to my phone and saw the background of the aPager (voluntary firefighter alarm) app. This App has the permissions to “overrule” all silence setting, can activate the display and send everything else to background (like the alarm…?).

As I disconnected the usb-c cable, the FP4 display went black und it tried to reboot. Since then, a reboot wasn’t possible. I don’t want to do a factory because of pictures from that weekend. Is there any chance to get the images from the phone before factory reset or doing some kind of cache wipe/Factory reset without deleting userdata?

I hate that “security” guidelines from google…

Edit: I tried rebooting several time, removed the akku.

Welcome to the community :wave:

What happens when you try booting your phone, at which point does it fail? :thinking:

If you are able, please try booting into Safe Mode, that will deactivate all 3rd party apps:

Maybe Nextcloud is still the culprit here.

Hey, thanks for your instructions. But also the safemode doesn’t work for me.
What happens during boot:
Fairphone writing.
Than the 4 blue circles apper and “dance” clockwise over the screen for about a Minute or two (I think, some kind of watchdog of bootloader triggers),
then Fairphone writing again und recovery kicks in saying, that my phone couldn’t boot and I may have to do a factory reset. 2 Options: Try again or Factory reset.

Alright, so it’s at least booting, that’s something :slightly_smiling_face:
You haven’t used your phone with adb before by any chance, did you? :crossed_fingers: So we could maybe try to get some logs during the boot process…

If the answer is no or you don’t know what that is, my advice would be to try to get into Safe Mode some more times. The timing can be a bit tricky, it always takes me at least 10 tries to get there when I have to use it.


No success.

Maybe I can just reinstall the actual FP-OS via adb sideload from within recovery? I didnÄt activate adb inside developer options. Was no need for that till now…

Not going to work, sorry, you need an unlocked bootloader to install the FPOS factory images, and you would lose all your userdata during that process anyway.

Hmm, or maybe you could try performing an OTA update from within Recovery. I’m not sure if that’s going work, but worth a try. Do you remember which version you were on?

Good morning! Had to go to bed…

no, within recovery there is no OTA-Option.
Reboot system now
reboot to bootloader
Enter Fastboot
Apply update from adb (that one I hoped for)
Apply Update from SD card
Wipe data/factory reset
mount /system (for hatever reason)
view recovery logs
Run graphics test
run locale test
power off

Edit: I cannot remember the exactly version. But i can remember, that I installed the last Version with Android patch-level 1st June… Is that Setup via SD your mentioned OTA-Aupdate, but via sd?

Apply (OTA) update from ADB is the one you want (technically via SD card would be possible too).

To be clear, if you didn’t have data on your phone you need to recover, I would just recommend to Wipe data / factory reset it.
This is a complete shot in the dark, might work, simply fail during the update or worst case screw things up completely, you have been warned. I’m not even sure the FP4 OTA updates can be installed that way, it’s been a while since I’ve tried.

Alright, patch level June should be the previous A.142 version, so grab the latest A.149 one…

… and try adb sideloading it :crossed_fingers:

1 Like


the update completed with status 0 (I think, that’s successfull). Now reboot…
blue circles are there
First try: nope, new reboot, but without recovery…
Secend try: nope again, third try to boot without watchdog kicking in.
third try: nope… still no watchdog. trying to press vol down for safemode…
Fourth try: Nope…
Any suggestions? Soldering the flash chip from the board? Or is it encrypted?

Sry, that with soldering was a joke.
I will do the factory reset…

– Wiping data…
E:Reverting to old slot since update will be deleted.
E:Error opening trace file: No such file or directory (2)
Formatting /data…
Formatting /metadata…
Data wipe complete.

Yeah userdata is encrypted :see_no_evil:

Bummer it didn’t work, hopefully your phone at least starts working again without problems after the reset.

Thank you very much for your support.
I will use syncthing in future, so immediat backup will happen :smiley:
Yeah, the FP4 booted, with .142 software and wants me to update to -149, again. Bit that goes in line with the message from the factory-reset.

So, in conclusion, Factory reset was the only solution, no data recovery possible. But at least, you help me a lot by trying it :slight_smile:
Now, reconfiguring all apps. I don’t allow google to store my app-data/configs.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.