Bootloop after Marshmallow Update

I’m assuming this is the Marshmallow update.
I used the self updater and the phone burned through 70% of battery within an hour while booting and optimizing/recompiling the apps again and again.
I’ll try later to apply a fresh flash so be warned this might not work as intended!

there is a major chance you will have to factory wipe your phone!

Troubleshooting wiki:

If you haven’t upgraded yet

Follow these steps to avoid the boot loop:

If you’re in the boot loop

Try this to get out:

  • If you prepared your device as mentioned above (no system modifications and the G%§$e App enabled) then you probably don’t have the actual boot-loop.
    • If your phone gets very hot cool it down and try again later making sure it stays cool
    • The optimizing apps process may take a few times. If however it continues looping and the number of apps to optimize doesn’t steadily decrease read on:
  • If you are in the actual boot-loop you’ll have to go to #dic:recoverymode (click to see the new way to navigate there in Android 6) to perform a #dic:hardreset.

After successfully booting

Do this to avoid further boot-loops:

  • If you want to disable the Google App again, set the Assist app to None before you disable the app: Go to Settings / Apps / :gear: / Default Apps / Assist & voice input / Assist app and set that to None. Even if it already says None, open the menu and explicitly select it!
  • As for system modifications you’ll need to undo them before any OS update.
  • Before the next OS up-grade (Android Version changes) we’ll have to check if G%§$e introduces new features that cuasue boot-loops and how to avoid them.

This issue is on the official #bugtracker

As a feature request to disallow disabling the Google App unless you set the Assist app to none before:


“We don’t judge, we just observe.” :slight_smile:

Is it “safe” to turn of the phone when in this bootloop!? Mine has been at is for two hours…

I think it’s better for the phone to take out the battery and let in cool down than to let it go on and get even hotter.

1 Like

Ok. I have done this and well let it cool down and start again. Hope it works next try.

It seems I am still in an endless loop… does anyone know a way to get out of this loop? I have removed the cover, and the phone is on a cold table of metal with the window open.

Usually I’d advise you to go to #dic:recoverymode and try to apply the update manually from there, but since the OS is not yet officially announced there are no files to download anywhere on the homepage yet. :confused:

PPS: I changed the topic title to make it easier to find for other #marshmallow updaters.


Thank you. I have no found my way to the recovery mode. Can I place this folder on the sd card and then boot from the sd card as shown here?

In recovery mode a managed to do a factory reset - this resulted in an updated system, Android 6.0.1. But with the entire phone wiped… still better than nothing :slight_smile:

Got the same problem here. Endless “optimizing apps” boot loop. Can’t even get into recovery mode (“no command”). The phone is actually bricked now. :frowning:

Recovery Mode works a bit different on #marshmallow. Check out the dictionary entry, I just updated #dic:recoverymode.

Mine showed “no command” on the andriod as well… but was able to reset to factory mode…

I have the same problem. It’s been doing this for about 5 hours now. I’m not sure what to do. I don’t like the idea of my ‘entire phone wiped’, when I apply the solution suggested above.
Is there any other way?

Thanks a lot! I almost started getting desperate. :wink:
In recovery mode I first tried “Wipe cache partition”, then reboot, but that didn’t help. I had to do a factory reset. Now the system has booted to 6.0.1. :slight_smile: Well, I actually planned something different for this evening than restoring all the apps and data, but that’s life.

1 Like

I have the same problem.
But I didn’t give up yet … :smiley:

Have you tried cooling the phone down?
If you wait for an hour or so (erm, 10 mins are probably enough) with the battery removed and then turn the phone back on with the backside of the cover removed and close to an open window (just make sure no snow can’t enter the phone) then chances are it will finish optimizing all apps and then boot normally.

Seems strange, but I will try this.
Can I take the battery out at any moment during this ‘optimizing’?

Yes that seems to be the best way to stop the process.

I just tried the ‘cool down option’, no luck. I’ll give it a really long cool down now, until tomorrow morning, but am getting worried that it won’t work.