Bootloader Unlocking site throws invalid IMEI / serial number error


I bought a new FP3+ directly from the Fairphone store. I set up the phone, connected it to wifi and updated everything on the system. Then I tried to unlock the OEM bootloader, but the official site:

gives me the error
The IMEI and/or serial number is incorrect. Please check for typos.

Now I double and triple checked everything for typos. I even read the two numbers via adb and copy & paste it to make sure there was no mismatch. Still the same error. I tried different browser on different machines, yesterday and today.

I also tried the various scripts that are online to generate the unlock code without the official website but I get the error in the log:

I OemUnlockPreferenceController: mVerifier == null ? true
I OemUnlockPreferenceController: invoke mVerifier.queryVerifyResult()----password=XYZ
D OemLockVerifier: queryVerifyResultGet--targetUrl=
D OemLockVerifier: queryVerifyResultGet--oem Lock verifier Start
D OemLockVerifier: acquireWakeLock
D OemLockVerifier: wakeLock acquire.
D OemLockVerifier: WARNING: Hostname is not matched for cert.
D OemLockVerifier: queryVerifyResultGet()--resp_code1=404
D OemLockVerifier: queryVerifyResultGet()--verify_code1=
I OemUnlockPreferenceController: Verify oem lock Result : 404,msg: URL not found

Any Help?

Thanks and BR

1 Like

Have you tried unlocking it without a SIM card installed and does the IMEI in the log match the IMEI that is printed on the device?
Another user reported a similiar issue where the IMEI was missing the last digit.

Same issue here. I raised a ticket to the support. Copy pasted the imei from the device, rewrote it from the box on the website… I even tried with the code generator proposed in other thread. With or without sim card, still same error message.

I never installed the SIM in the first case. I thought that might be a problem and tried it with SIM over mobile network later. Same problem.
The IMEI must be correct, it’s same number shown in Android Settings, as well as reading over adb commands, as well as printed on the package of the phone.

I just tried the website with the IMEI and Serial of my FP3 (non-+) and it did work fine and give an unlock code (which I cannot try as it is already unlocked).
So I can only recommend contacting support as it might be an issue with their database or maybe @jftr could have a look again?

Note: The custom scripts for generating unlock codes only work for the FP3 with Android 9. Since Android 10 the unlocking code is (unfortunately) not completely on the phone anymore but based on a database on the fairphone servers.

1 Like

For the adventurous there are in fact some other options:

  • flashing the devinfo partition using EDL mode, see Fairphone 3 unlocking without oem unlocking
  • trying to MITM the requests to the unlock server and faking a correct response as described here: /e/ OS Q (Android 10) for FP3/FP3+ - #14 by _tmp
    (When I looked into the android 10 unlock code a few month ago it did not verify that the ssl certificate matches the hostname which is indicated by the not really correct WARNING: Hostname is not matched for cert. entry in the log)

Yeah, I just tried the scripts to see what the adb logcat would show.

D OemLockVerifier: queryVerifyResultGet--targetUrl=

Indicates that an URL with the phone IMEI + serial number is queried, and the status code 404 shows that URL does not exist (or cannot be reached). Probably it is generated with the official website, which I can’t use.

I opened a support ticket already and hopefully they can sort this out.

Thanks for you help, though!

1 Like

well, as @_tmp tried its own serial / imei, the 404 indicates that our phones are not in the database behind the service. Hope it’s just a default in the sync system and not something worst :-/

Yes, let’s see if it’s a problem on the fairphone side. I would wait for their response before flashing either custom devinfo partitions or reconfigure my router. If I hear any solution from the support I will let you know, if you hear something @Keguira feel free to post here as well.


Few things from my Fairphone bootloader unlocking experience:

  1. Fairphone made modifications to the back-end systems for unlocking bootloaders between Android 9 and Android 10. You may want to ensure that there are no pending updates.
  2. Also if you have the fastboot command-line tool setup on your computer and get the phone into fastboot mode by pressing the volume down and power button simultaneously may want to give this command a spin:
fastboot oem 8901_unlock

For a few users the above command has worked as a by-pass mechanism.

1 Like

Thanks for your input.

The system is completely up to date, I checked that. The problem is not that the code fails while entering, but that the official website doesn’t even return a code for my IMEI / serial number. It always returns an error saying the numbers are incorrect. Multiple users seem to experience the same problem on the fairphone website although providing valid IMEI / serial numbers.

I have already tried the

fastboot oem 8901_unlock

command, but it was removed from the platform tools and is not available any more.

1 Like

ok, tried it this morning : the fairphone page returns me a code now and it was accepted by my phone. Yeah it’s possible it takes time after activation to authorize unlocking


I also had this problem “incorrect number” yesterday and contacted Fairphone support. An hour later I was told to delete all cookies and try again in a private window. I thought at first, usual blah blah, but did it anyway. Lo and behold, I got a code displayed.

Of course, I don’t know if Fairphone Support has done anything else :wink:


Same here, although deleting cookies / different machine did not work for me yesterday. I tried it on the same machine today and magically I got a code.

I guess they updated the database with the new IMEIs :wink:

Anyway, glad it worked and happily running /e/ now.


as for /e/ , i think i’m going to make a feedback later. Some things are really not cool out-of-the-box.

Hopefully any issues you have with /e/ will be a new post or even more than one as it’s easier to follow a simple thread. Hope it’s not too bad?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.