Boot Loop on new FP2 after trying to install fp open

I got a fairphone 2 yesterday and it worked totally fine on the preinstalled android, but i wanted to install Open, followed the instructions from the website etc and it seemed like it was fine, told me to restart, but then nothing had changed. i tried again and again and at one point, it went into Fastboot for some reason. I tried to do a hard-reset, didnt work. my brother then figured something out with manually installing Open. Seemed like it would work, it booted, told me it was optimizing apps, and now it’s in a circle of booting, optimizing and crashing again.
i took out the batteries and let it run out of power, didnt help.

please help me!

Which website do you followed instructions from? This? Which method? We could review the process with more info.

Have you data in the phone? (= did the process erase the user data?)
Some Google apps data may be conflicting. FP Open, as you know, don’t have any Google.

yes, from that website, using method 2 (after trying method 1 again and again without success).
No data was erased, there wasnt much on it since it’s brand new, but all google-based apps, like the play store, were still on it and functioning and in settings it said it’s still on fairphone os 1.7.1
which is why i tried the manual method using fastboot. at this point the phone was stuck on the ‘Fairphone powered by android’ screen, taking out batteries didnt help.
the manual method seemed to be working at first until it got to ‘optimizing android apps’. there it crashed and started rebooting and it’s been doing that since then. hard reset doesnt work, taking out batteries doesnt work, letting it run out of battery and trying again doesnt work either.
thanks for your help!

solved it! went into recovery mode and was gonna manually install android again, but it opened a recovery menu that allowed me to wipe the phone, rebooted and it works! it’s even on Fairphone Open now. idk exactly how that happens, but whatever

1 Like

When you install a new ROM don’t forget to wipe the cache, else the OS will consider it has already been setup (but since setup has been done on another OS it won’t be able to boot correctly). Wiping the phone from the recovery is the equivalent of what used to be called “Factory reset”

1 Like

Just to be clear, wipe cache alone is not a factory reset. The latter includes wipe data and wipe cache.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.