Boot crash after changing SIM, Avast anti theft locks and do not recognise unlock code nor unlock command from Avast site, and crash

I changed SIM card.
Another company to receive my money, but both this and the former use the same, real network operator (telia), and same phone number.
I shut down, removed battery, removed SIM from slot1, put in the new SIM in slot1, put in battery, power on.
Result:
Black screen with dead android in the middle, at the bottom this message:

E:Can’t open /dev/block/platform/msm_sdcc.1/by-name/misc
(Permission denied)

at the top in red:

Andriod system recovery <3e>
r4275.1_FP2_gms43_1.2.8

And a choice of actions.
I chosed reboot and it did.

Now it did boot up to Avast Anti theft alarm.

Avast anti theft trigged also after the update of the FP2 operating system a while ago.
Then, i could just unlock it with the code Avast sent by SMS to my wifes telephone, so was OK, although not expected (by me at least)

But this time Avast do not accept the code regenerated that way. Neither yesterday or new tries today.
Strange details: first time when i click antitheft interface unlock button it works (the button) and a numeric keypad is shown on top of the input field (bad design!).
After that first falled attempt the unlock button is dead.
But i can press the emulated physical center andriod button (th eone with printed circle on) to show my start screen with background, app icons and messages. Clickiing the avast message brings up a full screen semi translucent keypad looking like the SIM card PIN dialog (complete with emergency call button), but it accepts neither the Avast unlock PIN nor SIM card PIN.

By mail i get message from Avast and it positioned my phone correcttly, not by GPS, but by wifi networks.
(I guess google have been spying that up)
I can send some commands from Avast website to control the phone. As before, most fail.
I bought a premium account so i should be able to upload contacts get photo etc. Most commands always fail as usual when i test and i have been to lazy to complain to them, i admit.
However, on third attempt and placing the phone in very good reception location, i managed to get the message to shut down the siren thropugh, and the message to unlock it.
When i got back at the phone there is a message:

The process
System
Have crashed.

(I translate from swedish)
With buttons to wait more, or kil it. I chosed kill and expected a reboot.
Instead all is OK ! - except i had no mobile network…
Oh well, so i rebooted it.
Result: Avast antitheft trig again
I click to send unlock code and SMS is received at my wifes phone
Like before the (now fresh regenerated) unlock code do not work.
New mail from Avast, and the web now say my phone is 50 km away from here.
"Approximately, by wifi id"
This time the icon say i am connected to my mobile network.
I realised i could access some settings such as enabling mobile data, so i did.
But even after several attempts still no commands from Avast website works.

Any ideas what to do?

I put the SIM in old phone now, so no catastrophe.
But any idea on how to get my FP2 up again?
First thing when it is up, i will uninstall the Avast crap and ask money back.

Also restoring to factory defaults is OK.
I never store anything valuable in my phone except for short periods until transfer it to my local server.
And no i do not trust google or other “clouds”, by shear principle
(I installed antitheft because i think all phones should have it by default so thieves would not be interested in stealing them.)

Any idea what antitheft program works on FP2?
I tried Kapersky before, but it also had some non working functions (i do not remember details)

UPDATE: now after having written and edited the above, the alarm have stopped and it is unlocked.
It seems the unlock message succeeded getting through - after many minutes, strange.

Checking versions:
Avast Anti-Theft 3.1.7863
Avast Mobile Security: 5.1.2
Both installed 2016-02-21

Is someone interested in me investigating anything, or i should just uninstall them?

UPDATE2:

  1. I realised i can untick all actions on the web interface, so i did that (alarm, lock, simulate low battery, etc…)

  2. I also see the option to automatically enable GPS is selected, but that apparently did not work when it trig

  3. Some test of actions from web interface
    Show message: OK (shows white text on grey on phones whole display)
    Initiate call: OK (not very hidden though) I can listen what my phone hear, not talk to it.
    Make phone send SMS: Fail
    Take picture: Fail (both front and back camera options fail)
    Record audio: Fail
    Get position: Fail most tries despite good connection, end when it works, only by wifi id (in my settings position is off (i want to save battery. Apparently Avast can not turn it on itself. I have set it on now to see if it gets better.)
    Track: no response… ?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.