Bluetooth tethering to Tomtom Go50 does not work

I am trying to connect my Tomtom Go50 to internet via bluetooth tethering using the fairphone (first edition).

  • I have bluetooth activated and the TomTom Go50 is coupled (name is pressent in List of coupled devices).
  • I tick the box on Bluetooth-tethering
  • WIFI hotspot is off (also in ‘on’ i get the same problem as stated below)

If i start the connection from the TomTom, I get the message:

Verbinding van netwerktoegangspunten met TomTom go50 is verbroken.

And then the TomTom tells that it cannont make contact to the internet.

Who can help me to solve this?



I don’t have any suggestions for you, but it may be that this is related to other problems with bluetooth on the FP. The software team are looking at trying to fix as much of this as they can in the next update (fingers crossed).

Anyway, it may be worth you contacting support directly so that know of your configuration etc

Same here when trying to connect my Tomtom GO500 to internet via Bluetooth PAN tethering:

  • the coupling of both devices works,
  • then when the GPS actually tries to use the shared conection, a dialog “Authorize connection” flashes up and disappears without any chance of interaction
  • then i get the notification “Network access of TomTom Go500 has been disconnected” (or some phrasing to that effect on my French localization).

PS: This is on an FP1 2nd edition, running 1.7 Hazelnut, with no additional SD card installed.

OK, I will remain on this thread after all, because this seems quite TomTom-specific. Here is what I have found to date:

  • Bluetooth works on py FP: the A2DP connection to a speaker works.
  • Bluetooth PAN WORKS WITH MY COMPUTER (Macbook 2009 running OSX 10.10) : there, the same dialog that just flashes up with the TomTom remains displayed, so I can accept « Yes, share the connection », and then it works.
  • I have tried an app that manages BT PAN on rooted devices (search “Bluetooth PAN for Root Users” on googleplay); it reports “Bluetooth PAN not supported on your device. ---------- Your system does not contain the executable file /system/bin/pand. Further work is not possible !”. So no hope to get an alternative interface with a functional dialog.

It all seems to revolve around that validation dialog, that only flashes up and seems to get refused or cancelled by default when connecting to the TomTom, whereas it remains displayed and allows validation when connecting with the computer.

Addy, can you confirm that behaviour?


Oh yeah: I’m on an FP1 2nd edition, running 1.7 Hazelnut, with no additional SD card installed.

Hi Jan,

Have been away some time, so only now a response. I can confirm your observation that the connection is somehow refused. For now I wait until the 1.8 update and hope that it will be solved using this update.


Thanks Addy. Like you, I’m waiting for the 1.8 “sp1” update. It seems the FP team changed things about Bluetooth. Let’s hope!

OK, I needed the BT connection, so I took the plunge and updated to 1.8 despited its “not recommended” status. Actually I found it to be no big deal, sure all shortcuts had to be re-created and handling is a bit different, but with the tutorials from the website I got someting I liked, admittedly on a quite simple system (Home + 2 addtional sceens to the left, with about 20 apps or widgets).

The Hitch: BT connectivity to my TomTom Go500 is still defect. The behaviour is exactly the same as with 1.7, as described above. I guess I will put the issue formally to the support team and point them to this thread.

FP1U, 1.8 running - same problem here. Cannot connect with the Tomtom Navigationsystem via bluetooth. It would be very nice, if anybody could help me!

To the best of my knowledge, there is no solution or workaround at this stage.
We have to wait and hope for an update to Android 4.4 Kitkat. There are currently open community efforts (by Chris Hoffmann) that test this and demonstrate new BT capabilities, so this would perhaps fix the issue. But this is currently not even at the beta stage, no way to use this in daily use.
We have to hope for an official Fairphone update, which is still uncertain, essentially because Fairphone was screwed by the chipset manufacturer (Mediatek) over licensing agreements, on top of upgrades being already complicated because all subsystems have to be tested.
I see that the issue does not feature in the “known bugs” list, despite having been reported as a bug. I will send FP tech a message about that.


For clarity, I quote the message I received from support a year ago about this bug:

Unfortunately for you we don’t have the capacity and resources to look at this right now. :frowning:
In 1.8 we included a new set of Bluetooth profiles to try and solve the issue people had with their Toyota Touch and Go system. (and it also seems to solve some issues people had with other devices).
This update was brought out because there were a lot of people with this issue. Considering you and the other person on the forum seem to be the only people up till now that have this issue, I have to be honest to you. Personally I don’t think this issue will be looked into any time soon.

I will flag your issue into the bugtracker of our software team however I can’t guarantee anything.

As a last question to you I would like to ask whether this connection is Bluetooth Low Energy or just normal Bluetooth.

I am very sorry that I can’t help you better regarding this issue and for the inconveniences this causes you. :frowning:

Kind regards and have a great weekend!


It’s disappointing but at least it is an answer.


Was this ever resolved ? I have the same problem with a later tom tom model. According to the phone coop the phone does not support bridging the internet connection to bluetooth.

I am fast getting fed up with this phone and about to sell it on to a friend at a huge loss just to shift the damn thing. I am finding it hard to trust that the FP2 will be any better.

Have you tried installing the unofficial Android Kitkat:

I’m on Android Kitkat and Bluetooth tethering works with my laptop (I’m writing this very message from my pc through my FP1’s internet connection).

Never knew about that. I’ve ordered the FP2 anyway. I’ll try it out immediately and send it back if it deos not do what I expect it to. I don’t know where some of the limitations on FP1 come from but they are made. I don’t know when the phone was designed but it seemed out of date when I bought it.

The phone must have been designed well before the first Fairphone 1s were shipped in Jan. 2014 because it is a licensed Chinese design, which had been on the market already, when Fairphone were searching for a production partner..

It would be interesting, however, to know, if Bluetooth tethering to the TomTom Go worked with Kitkat 4.4.4…

Really ? so who designed it ? I always said it felt like an old phone but I know I was late to the game. I have the FP2 now, the bluetooth tethering works but it has a shed load of other problems, I wonder who designed that one.

4 posts were split to a new topic: Can a software update even solve a overheating processor?

Good news: with the latest update of the Tomtom GO software (15.600, published 14 january 2016), the tethering now works!

In fact, the GPS lost all its paired devices in the update, which prompted me to give my FP1U/1.8.7 another try. There was a bit of fiddling for pairing, and another few misses when getting the PAN going, but then, the famous “Do you allow the connection?” dialog could be brought up from the notifications, duly answered “yes, allow”, and then, lo and behold,
the connection worked.

In use it proves stable. A few hassles remain: the bluetooth network sharing function (in the “more>connection sharing” sub-menu in the settings) tends not to stick, and above all, this “Allow connection” notification shows up and has to be validated on each re-connection (if you miss the first one, which seems to get lost when unlocking the phone, hang on, you will get prompted again less than a minute later).
The FP is the ONLY Android or iOS device I know that systematically asks to allow network access for known (paired) BT devices. If this nag screen could be removed permanently it would be much simpler.

Good luck,

1 Like

It seems that this was a problem on the TomTom’s software side. Regarding the “allow connection” notification, I suggest you contact Fairphone support and ask them to remove this notification in the next update.