Bluetooth audio bug on Android 12

Thanks for confirming!

1 Like

I ended up installing Bluetooth Codec Changer which makes this a little bit easier. It also has an auto switch feature, but sadly that’s only part of the premium version ($3 one-time, so could be worse I suppose).


Thank you, too :partying_face:

The Bluetooth no-sound issue seems to be an Android 12 issue, not specific to Fairphone, but also affecting Pixel, Samsung and other Android 12 phones… Turning of HD in the headset bluetooth setting is a work-around that worked for me.

Since the Android 12 upgrade I’m not getting any sound through my pair of very basic Bluetooth earphones. They don’t support HD audio, so I can’t turn it off in the Bluetooth settings. Is there another workaround for this bug that might work for these?

Hi and welcome have you tried any other things like unpairing/repairing, resetting the headset…? I dont have any issues with any device not supportinf aptx…

Like here

Thanks for your quick reply. I had tried resetting the headset a few times without success. But now I have just told the FP4 to forget the device and paired it again as a new device, and it is now working!

How do I get to the Developer option?

Settings > About Phone > Build number > and tap 10 times
Settings > System > (Advanced) > Developer Options > ON

Search [Developer options]

1 Like

This is not only a fairphone issue…

1 Like

It worked fine for me when I had Android 12 for one year on my Pixel. On the day of release there were no issues. These issues are mostly due to the vendor implementation of Android 12.

Unfortunately after the Android 12 update my Bluetooth headphones don’t work anymore.

What exactly happens:

  • they connect with my phone
  • they are set for media audio
  • they are recognised in all apps
  • however, still no sound comes out of them…

What have I already done to try to fix it?

  • reconnect it to my Sony headphones app
  • disconnect and reconnect it to the device
  • check that my audio is turned on (it is)
  • restart both devices (FP4 + Sony Wireless Headphones)
  • turned off/on Bluetooth on both devices

The audio is still not working.
I didn’t find anyone else with the problem. If you have it, too, please mention it and your experiences. If you have other ideas for solutions, let us know :slight_smile:

1 Like

It seems like others have similar problems. E.g. a comment under this post: Android 12 has come to the FP4 - #50 by Anton_Lokke_Laursen Additionally there are apparently some who have general media audio issues.

In my case the normal media audio without Bluetooth seems to work without problems.

I have a half-baked solution:

After turning off the HD audio on my headphones it is working. However, this is somewhat of a disappointment as now one of the core features of my headphones is permanently disabled.

Do you have a better solution?

1 Like

There are many others having this issue and its being worked on, please read above.


Is anyone else also finding their WiFi seems to impact their Bluetooth connection? Sometimes it flickers in and out a bit, it seems to be when WiFi is struggling to connect to a bad signal. Perhaps this was always there but never really noticed it before. Like if Bluetooth audio is being spotty in my headphones if I flick WiFi off it seems to resolve it? Making a hotspot makes it much worse

WiFi/Bluetooth problem others similar, guess I can try those steps if it becomes a problem
Aware they use the same frequency. Not always able to use 5GHz, don’t remember them problem being marked before android 12 but maybe I’m just paying more attention currently

Bluetooth uses the 2.4GHz band of EMF as does the 2.4GHz.

Stop the 2.4GHz Wi-Fi option on the phone from connecting automatically so that the phone uses 5GHz

1 Like

Hello, I take it you were referring to the advice in the thread about turning off the HD audio in the Bluetooth Device details of the paired earphones/speaker/device; it has worked! Thank you!



since I got the update to Android 12 the “HD-Audio” (i.e. aptX Adaptive) does not work correctly anymore. Apps like Spotify “play” the song, but there is simply no sound from the headphones.

When I turn off the HD-Audio I get sound, but in poorer quality. aptX worked before with Android 11 and also works perfect with Android 12 on my Lenovo tablet. So it is not a general Faiphone nor a general Android 12 problem, but especially the problem of a buggy Fairphone-4-Android-12 firmware.

I found a similar Thread here:
However it was closed although not solved. I don’t really understand why.

Will there soon be a bugfix available?

See the link in the final post . . .