Bluetooth audio bug on Android 12

Looking forward to them fixing HD Bluetooth!

1 Like

Android 11 with Bowers & Wilkins Px8 - AptX worked fine

Adroind 12 with Bowers & Wilkins Px8 - nothing works at all. Phone shoes that the aptX Codec is active and the sound is running but now played on the headphone.

How long does it need for a fix? I am not the smartest fp user, so downgrading to Android 11 might kill my data xD

Any experiences?

PS: A2DP disabling doesnt change stuff and also disabling aptX in developsettings didn’t fix the problem.
PPS: Yes aptX was not shown on the technical details … I went to a shop and tried a headphones, they worked, I bought them … coming up with “havent you read the technica lsheet on your phone blah” is definitely the wrong way to approach people in this thread.


1 Like

It may not be the most useful/helpful etc. but the ordinary users that respond spend a lot of time answering issue that people could have found themselves had they put some more effort into it.

So it’s definitely not the wrong way to approach people when it seems they could have done more research on this forum before asking for help.

It’s a bit blunt, no doubt, but gladly somehow you got to the


As I’m not certain you’ve tried in the correct place or if anyone else gets lost, I believe the simplest/main workaround isn’t using the developer options, but to turn off HD aptx within Connected Devices (Bluetoothl settings - click on the cog next to the connected device to get to Device Details as seen here:


I am also having issues with my bluetooth from my fairphone to my earphones after the recent update. It manages to connect the devices but then when I try to play music I just hear clicky noises in the earphones. The phone was able to connect to a different wireless speaker, and the earphones are working fine connecting to my laptop, so I am not sure what exactly has gone wrong; it seems the phone has taken specific issue with the earphones! The earphones are goji GTCIBTB18. I have tried the “forget device” option for the earphones, in the bluetooth settings, and then the restart in Safe Mode (to disable 3rd party apps) but it is still doing the clicky noise. Any suggestions? Thanks!

1 Like

Assuming you updated to Android 12 I moved your post here, please read above

If you use high quality ear buds and pay attention to good sound, it IS important, as it makes a real difference.


It’s the simplest, but for those who are audiophiles and really concerned about the best quality, there is also the option to have that. :wink:

It’s almost a necessity to be honest, because the LDAC bitrate is about double that of aptX HD, but for whatever reason FP always defaults to aptX when HD-audio is enabled, so if you want the best you have to regularly tweak the settings anyway.

The FP4 supports AptX HD. This new issue is unique to the latest software update.


Thanks for confirming!

1 Like

I ended up installing Bluetooth Codec Changer which makes this a little bit easier. It also has an auto switch feature, but sadly that’s only part of the premium version ($3 one-time, so could be worse I suppose).


Thank you, too :partying_face:

The Bluetooth no-sound issue seems to be an Android 12 issue, not specific to Fairphone, but also affecting Pixel, Samsung and other Android 12 phones… Turning of HD in the headset bluetooth setting is a work-around that worked for me.

Since the Android 12 upgrade I’m not getting any sound through my pair of very basic Bluetooth earphones. They don’t support HD audio, so I can’t turn it off in the Bluetooth settings. Is there another workaround for this bug that might work for these?

Hi and welcome have you tried any other things like unpairing/repairing, resetting the headset…? I dont have any issues with any device not supportinf aptx…

Like here

Thanks for your quick reply. I had tried resetting the headset a few times without success. But now I have just told the FP4 to forget the device and paired it again as a new device, and it is now working!

How do I get to the Developer option?

Settings > About Phone > Build number > and tap 10 times
Settings > System > (Advanced) > Developer Options > ON

Search [Developer options]

1 Like

This is not only a fairphone issue…

1 Like