Bluetooth audio bug on Android 12

Just found this thread while having the same issue with my new Fairphone 4 and Sony WH-1000XM3s. Pleased to see that Fairphone team are already on it!

SBC audio not terrible in the meantime but it will be nice to have the LDAC setting persistent

1 Like

Same here :frowning_face: : since my FP4 upgraded to Android 12 FP4.SP1Y.B.041.20230109, my Sennheiser Momentum 2 don’t play any sound any more.
Am very looking forward to hearing Sennheiser Momentum 2 playing sound from my FP4 again.

BTW: Bose SoundLink Mini is working fine, and so does an old Plantronic PLT_M55 headset.

Update: switching off HD-Audio aptX does work around the problem for me.

Try this

This can only be a temporary solution, no mini jack and no aptx support are a definite exclusion criterion for me.

Welcome to the forum!

For me the words In the meantime and temporary workaround describe it as a temporary solution here…:

Simply not true.

Was working with aptx adaptive until Android 12.

No clue on how you can tell it like that. See feedback from Fairphone.

1 Like

I’m not lying, maybe misinformed. AptX is not listed as a codec for the FP4 and FP support did mention to me once that AptX is not included due to licensing or something.

@Yasen_Tomov, sorry to drag you into this. Could you confirm or deny this? Does the FP4 have support for AptX? And if not, why did it work before? Was that just a transparent fallback in the background to e.g. AAC? And thus users may simply not notice that they’re actually using AAC. And perhaps this fallback mechanism is now buggy/broken in Android 12?

2 Likes

This supported codec list you show is for playback. Not for Bluetooth.
Otherwise it would say you can play AAC+ or FLAC via Bluetooth, what is not the case.

I find it confusing as well, because SBC would be missing in that case. I’m just repeating what support told me with this list. If we cannot trust that as a source, then I don’t know what is.

I am sorry but this time the support was wrong to you.
I trust the Fairphone answer in one of the threat that dev team is taking care of it to correct.
And as I have a 4 - I can tell you that aptx - until adaptive, (TWS I could not try), AAC, LDAC was working. Even AAC is still working with 12. Prove by the receiver that show the type of codec used - in addition to the message in Fairphone 4.
To my knowledge:
In case you have a SoC from Qualcomm - you get by default aptx support as it is built-in in hardware.
If you get aptx adaptive or hd do more pend on type of chip and modem used.
Aptx is qualcomm proprietary content - and so I can understand you need license if you do NOT use SoC from Qualcomm.
Here Fairphone do have Qualcomm - and so you have aptx support.
I do not have heard of any smartphone with Qualcomm NOT having at least one aptx codec. This since my first - HTC Desire.
It would be more questionable for LDAC support as SONY proprietary Codec. But even this runs with the Fairphone 4.

As even the aptx is not working - that must be a configuration error in the kernel modules in Android12. The behaviour of Video playback (slomo) is for me a clear indicator.

2 Likes

To complete:
LDAC is still working with Android 12.
Only aptx - in all version - fail.
So I can still use my PX7 with appropriate codec - but need a Fiio M5 in the middle.

Hi there,
I also can confirm that aptX did work on FP4 Stock Android 11 with 2 different bluetooth audio devices capable of aptX. Since update to Android 12 only silence if I use HD-Audio and aptX is shown in the properties of the bluetooth connection. Switching off HD-Audio immediately solves the problem.

I’m not happy with this solution. Audio quality has significantly degraded :frowning_face:

Please solve this issue, dear FP-Team!

Robsn

1 Like

Hi and welcome to the forum.

As this is a user forum with Fairphone only really reading responses to their own posts you may find it more satisfying to contact Fairphone via their support page or by email to support@fairphone.com

See also

Fairphone already accepted this bug and confirmed to work on it, no need to bother support with this

4 Likes

I can confirm, the issue only appears when using aptX; if you go to developer settings and switch to something else (in my case LDAC), the audio is back.

If someone from Fairphone is looking at this thread: It would be nice if, in addition to fixing whatever issues there are with aptX, the phone could default to using the highest-quality codec available for a given headset as well. I raised this issue with support about a year ago and was told there is not enough interest to consider a fix, but since Bluetooth audio is getting some attention now anyway, maybe the codec prioritization could be tweaked as well. I shouldn’t have to manually switch to LDAC from developer settings every time I connect my headphones to get the best-quality audio available.

3 Likes

Looking forward to them fixing HD Bluetooth!

1 Like

Android 11 with Bowers & Wilkins Px8 - AptX worked fine

Adroind 12 with Bowers & Wilkins Px8 - nothing works at all. Phone shoes that the aptX Codec is active and the sound is running but now played on the headphone.

How long does it need for a fix? I am not the smartest fp user, so downgrading to Android 11 might kill my data xD

Any experiences?

PS: A2DP disabling doesnt change stuff and also disabling aptX in developsettings didn’t fix the problem.
PPS: Yes aptX was not shown on the technical details … I went to a shop and tried a headphones, they worked, I bought them … coming up with “havent you read the technica lsheet on your phone blah” is definitely the wrong way to approach people in this thread.

Asap

1 Like

It may not be the most useful/helpful etc. but the ordinary users that respond spend a lot of time answering issue that people could have found themselves had they put some more effort into it.

So it’s definitely not the wrong way to approach people when it seems they could have done more research on this forum before asking for help.

It’s a bit blunt, no doubt, but gladly somehow you got to the

:slight_smile:

As I’m not certain you’ve tried in the correct place or if anyone else gets lost, I believe the simplest/main workaround isn’t using the developer options, but to turn off HD aptx within Connected Devices (Bluetoothl settings - click on the cog next to the connected device to get to Device Details as seen here:


3 Likes