Bluetooth audio bug on Android 12

I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

1 Like

Hi and welcome to the community, I moved your post, please read above foe further workarounds while waiting for a final fix

1 Like

The reason I posted were I did is because the creator of the thread wants feedback on the latest software update. This thread is has no solution for my problem. I’m reposting in the original thread hoping my feedback will be left there.

The poster also posted here and we keep for specific wide spread issues own topics and therefore move posts as needed.


Hi @yvmuell ,

i hope it comes a new fix. Did a fairphone employee give feedback that it will be fixed at all?

Hi, thanks for starting the thread with update issues.
I don’t know if it is related but since I installed the update, I cannot connect any more to my headphones via Bluetooth. This worked without problems before. Now, the headphone shows that I am connected, the FP4 shows that I am connected, but the sound remains with the device, and the headphones remain deaf & dumb.
My Fairphone’s build number is FP4.SP21.B048.20230215, too…do they all have the same number?

Thanks a lot for everyone who knows what to do - I need my headphones all the time for video conferences, and MS Teams/ Webex don’t work well with Linux but, until the update, they DID work with my phone.

1 Like

I moved your post here pleaeßse read above

1 Like

I have the same headphones (Sennheiser HD350BT) and turned off aptx qualcomm/HD audio and it worked. Haven’t tried anything else since then. Just for information in case it’s relevant.

I had the same issue since the 13th of Feb update, with “MOMENTUM On-Ear 2 - Sennheiser” headphone and Managed to solve it with workaround 1 above. Many thanks !!

Using libratone track+, fp4, latest Android 12 update.
All Bluetooth working fine both AAC and SBC.
BUT: whatever I do I don’t get Ms teams app to work with the headset anymore.
I know the Ms troubleshooting for that, using both cache delete and reset of bt connection.
Still no headset on fp4, company profile and bt device.
Anyone seen this behavior?
I completely depend on teams and need to work hands off the phone.

Just adding my 2 cents. I recently got a Sennheiser Momentum 4 headset. Music does not play (it usually immediately stops whatever app is playing). I turned off any features of the headset like auto-pause.
In order to play music, I have to go to the developer settings and choose aptx-HD instead of adaptive aptX. I use AVRCP v1.6, MAP v1.4 and 44.1 kHz@24 Bits per sample. Fairphone 4 is updated to the newest firmware. I would love to use adaptive aptX.

I just realized that not only aptx ist broken. I switched back to my bose Headphones (cable) - and the Sound is crap - Like through a tin can. Normally they Sound very good. This makes me believe that there ist a major issue with sound which goes much further than just Bluetooth…

I have Sony WH-CH510 headphones which use an A2DP connection: SBC and AAC codecs.
The messages above suggest this should work but since the updates my phone won’t connect.
Any ideas?

It would really be appropriate to get feedback on whether the problem was accepted. AdaptX HD was fixed, but not the other variants. Anything else coming up?

Define “won’t connect”: It did connect before and now it does not connect any longer? Or it ever could connect?

If it worked ever before: try to remove the existing pairing on the phone and re-pair the headphone.

I have Sony MDR-1000X and manually have to select LDAC in the developer options instead of aptX. The settings are not persistent, so aptX is selected by the phone each time I connect the headphones.

It would be great if Fairphone could fix so that LDAC is persistent when you fix the other issues. LDAC sounds better on my headphones at least.


I have a Devialet Gemini Headset, same issue, same work around expect for the Hd sound toggle in the bluetooth headset config that is not available.

I hope FP will fix this bug in the next update…

If you want to have a persistent change, you must not use the developer options but you need to turn off the “HD audio” option in the Bluetooth settings of the headphone.

If you want to use at least LDAC, you can use the Bluetooth Codec Changer app as mentioned above. This will automatically set the desired codec for the device as soon as the connection is established.


I have related issue but with car (VW T-Roc) audio. When I try to call via car’s infotainment system, car audio produced “radio freq” type of noise. There is a “HD audio: AAC” toggle for this BT connection but making it ON or OFF doesn’t make any difference.
Anyone having similar issues ?

ArtūrasB. (FP4)


This software doesn’t work for APTX adaptive. I have Bang&Olufsen BEOPLAY EX earbuds and I STILL can’t hear music on m’y phone.

What are the solutions for people who have earbuds that only works with APTX adaptive?