Bluetooth audio bug on Android 12

Jabra Elite 3
Available Codecs: sbc, Qualcomm aptX-Audio (nb: Qualcomm aptX-HD ist NOT available)
Working: sbc
Broken: Qualcomm aptX-Audio
And yes: there ist the below mentioned “faint clicking noise” when selecting aptX-Audio
Regards. and thanks to everyone trying to get these issues ahead. I feel so stupid having given a chance to FP4 after a frustrating single year with FP2 - the least sustainable Cell Phone I have had so far.

1 Like

Not having a device with AptX just reading above detailed explanation and seeing your screen, your device offers Aptx and not AptxHD and therefore for you HD Audio is broken


The Bluetooth option from the headphone called HD-Audio: Qualcomm aptx-Audio. nobody cares which codec is behind it. And nobody has to understand that they ONLY fixed aptx HD.
Fix the Bug!

1 Like

Hi you do realise this is just a user forum, so such demands/commands are inappropriate.

Further: Fairphone do monitor the topics they create and so it is better to add your comment to the their last topic which is the System Update.


Wrong, my devices offer it, I just had to turn it off so that I can listen to music again.
I just wanted to point out the “HD Audio”.


1 Like

Same here. With KOSS Porta Pro Wireless

working bluetooth codecs : SBC, AAC ,aptX HD ,LDAC
not working : aptX

tested with FP4 on Nuber A-125 and Sony WH-1000XM2


Again to anyone here:

From previous posts I installed:

Bluetooth Codec Changer.

It works quite well to quickly switch the CoDec.

You will easily find out what your device is offering.

What is working:
SBC (seen as SD in Bluetooth selection by Android, so what is used when toggle “HD” is off)
AAC (Already the first CoDec seen as “HD” even if this is wrong)
APTX-HD (that is the older high quality one}
What is not working
APTX adapted (that is the newer high quality one)
What is unknown


I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

1 Like

Hi and welcome to the community, I moved your post, please read above foe further workarounds while waiting for a final fix

1 Like

The reason I posted were I did is because the creator of the thread wants feedback on the latest software update. This thread is has no solution for my problem. I’m reposting in the original thread hoping my feedback will be left there.

The poster also posted here and we keep for specific wide spread issues own topics and therefore move posts as needed.


Hi @yvmuell ,

i hope it comes a new fix. Did a fairphone employee give feedback that it will be fixed at all?

Hi, thanks for starting the thread with update issues.
I don’t know if it is related but since I installed the update, I cannot connect any more to my headphones via Bluetooth. This worked without problems before. Now, the headphone shows that I am connected, the FP4 shows that I am connected, but the sound remains with the device, and the headphones remain deaf & dumb.
My Fairphone’s build number is FP4.SP21.B048.20230215, too…do they all have the same number?

Thanks a lot for everyone who knows what to do - I need my headphones all the time for video conferences, and MS Teams/ Webex don’t work well with Linux but, until the update, they DID work with my phone.

1 Like

I moved your post here pleaeßse read above

1 Like

I have the same headphones (Sennheiser HD350BT) and turned off aptx qualcomm/HD audio and it worked. Haven’t tried anything else since then. Just for information in case it’s relevant.

I had the same issue since the 13th of Feb update, with “MOMENTUM On-Ear 2 - Sennheiser” headphone and Managed to solve it with workaround 1 above. Many thanks !!

Using libratone track+, fp4, latest Android 12 update.
All Bluetooth working fine both AAC and SBC.
BUT: whatever I do I don’t get Ms teams app to work with the headset anymore.
I know the Ms troubleshooting for that, using both cache delete and reset of bt connection.
Still no headset on fp4, company profile and bt device.
Anyone seen this behavior?
I completely depend on teams and need to work hands off the phone.

Just adding my 2 cents. I recently got a Sennheiser Momentum 4 headset. Music does not play (it usually immediately stops whatever app is playing). I turned off any features of the headset like auto-pause.
In order to play music, I have to go to the developer settings and choose aptx-HD instead of adaptive aptX. I use AVRCP v1.6, MAP v1.4 and 44.1 kHz@24 Bits per sample. Fairphone 4 is updated to the newest firmware. I would love to use adaptive aptX.

I just realized that not only aptx ist broken. I switched back to my bose Headphones (cable) - and the Sound is crap - Like through a tin can. Normally they Sound very good. This makes me believe that there ist a major issue with sound which goes much further than just Bluetooth…