Bluetooth audio bug on Android 12

The Update does not solve my troubles to pair the right Libretone track air+. After pairing the left one, a message should apear to pair the right one. This is missing. The left is pairing, but I had to turn of the HD-Audio aptX setting. The repairing when I take the left bud out of the charching box is not working. I have to go to bluethooth settings on fairphone 4 and touch on the Libretone track air+ entry. But then the left bud is working. Right one not at all.

1 Like

Tnx. Luckily the Cambridge Audio app provides the option to turn aptX of so thats a simple work around for me. Just wonder what I’m missing out on on sound quality. We’ll hopefully find out after some future update.

Man, it’s so ironic. They remove the headphone jack with the Fairphone 4 and then they break bluetooth audio for a lot of people. :man_facepalming:
Fixing this should be such a huge priority.


Well, this may be the solution for some but not all of us. So I think it is to early to mark this Thread with more than one Bug as solved… My Sennheiser Momentum still only works with SBC…
I hope FP is working on it and I am looking forward to the next sw-uodate (@Yasen_Tomov ?)

1 Like

Hi @gboss,

You are of course correct that this bug is not fully resolved. I think @yvmuell just marked the post as a “Solution” to make it easier for people to find the workarounds until further notice. I am fully expecting Fairphone to fix this bug for all available codecs, anything else would be disappointing.

And speaking of workarounds I believe all generations and versions of the Sennheiser Momentum series support at least SBC, AAC, and aptX, with newer generations in the Momentum series adding support for aptX Adaptive etc as well. As such you should be able to use AAC at the very least which still qualifies as “HD audio” in Android, and perhaps even aptX HD if you have a newer generation Momentum.

Have you tried downloading the Bluetooth Codec Changer app linked in my post, just to check what codecs your Momentums actually support, and trying to switch manually between them? This app will list all available codecs on not only the phone, but also on the bluetooth device so you can try them all and find the best option that’s still working.

For reference here is a handy table containing each bluetooth audio codec and their technical performance which might be helpful in choosing the best one, in case you find that your Sennheiser Momentum headphones support something better than SBC:


Bluetooth aptX HD Audio still not working.
Radio, car radio, headphones remain silent with aptX HD. :frowning:

Fairphone, how do you test? Do you test at all?


1 Like

When you read what FP stated, they exactly did fix this :upside_down_face:

Other improvements

  • A bug that was causing the Bluetooth audio to stop working when the aptX HD codec was selected, has been fixed.

Okay, I’m getting a headache again reading this…

The aptX HD has definitely NOT been fixed.


1 Like

Sennheiser unfortunately not support aptx HD. Only Aptx adaptive.
I do have the True Wireless ones and can chose between AAC or SBC as of now.
My B&W PX7 do work with aptx HD - They support all types of aptx - until adaptive - including HD.

So I hope Fairphone continue to fix the remaining codecs as well.


I see a few people claim that the aptX HD codec still doesn’t work for them.

I would like to know how you’re testing this if you are affected. Either its true that aptX HD codec is still broken for some users, or they are perhaps confusing aptX HD with androids “HD audio” name, or another version of the codec such as regular aptX or aptX Adaptive.

FP4 appears to prioritize the bluetooth audio codecs like this, from 1 being highest priority to 6 being lowest:

  1. aptX Adaptive (Broken)
  2. aptX HD (Working)
  3. aptX (Broken)
  4. AAC (Working)
  5. SBC (Working)
  6. LDAC? (Working. Does not seem to get used automatically?)

If your bluetooth device supports aptX Adaptive it won’t fall back to aptX HD even if aptX Adaptive is broken. If your device supports up to aptX it also won’t fall back to AAC even when aptX is broken. If your device only supports aptX HD as its highest level it should now work out of the box with the latest update. If your device only supports up to AAC or SBC it’ll work out of the box.

See my post here for some workarounds to get working “HD audio” even if your device won’t automatically fall back to a working codec by itself.

I hope this clears up any confusion for users. Of course this bug is not fully resolved until aptX and aptX Adaptive also works correctly. I am fully expecting Fairphone to fix this bug for all available codecs, anything else would be disappointing.

For reference during my troubleshooting I used a number of different bluetooth devices to test. I used both the hidden “Developer options” menu and the Bluetooth Codec Changer app to switch between the available codecs for each device to confirm which ones were working and which ones were broken.

Here are my findings in full:
All testing done with the FP4.SP21.B.048.20230215 update.

Fairphone True Wireless Earbuds
Available Codecs: SBC, AAC
Working: SBC, AAC

Sennheiser Momentum True Wireless 2
Available Codecs: SBC, AAC, aptX
Working: SBC, AAC
Broken: aptX

Bang&Olufsen Beoplay Portal PC/PS
Available Codecs: SBC, AAC, aptX HD, aptX Adaptive
Working: SBC, AAC, aptX HD
Broken: aptX Adaptive

Topping DX3 Pro+
Available Codecs: SBC, AAC, aptX, aptX HD, aptX Adaptive, LDAC
Working: SBC, AAC, aptX HD, LDAC
Broken: aptX, aptX Adaptive
Note: LDAC should’ve been used automatically as the highest quality option, but aptX Adaptive has higher priority in the system and thus necessitates extra steps for switching to LDAC. This should in my opinion either be adjusted or make it simpler to switch to LDAC as the default for devices that support it.

Additional observations
As noted by @RAD above in this post there is sometimes a faint “clicking noise” or perhaps “ticking” when selecting either aptX or aptX Adaptive for me on some devices. Perhaps this is some kind of artifact of the connection attempting to reestablish itself constantly or something. I’ll leave this to the developers to investigate.


Sorry, it seems really only HD audio does not work, but what else worked under Android 11.

Here is an example::

1 Like

Jabra Elite 3
Available Codecs: sbc, Qualcomm aptX-Audio (nb: Qualcomm aptX-HD ist NOT available)
Working: sbc
Broken: Qualcomm aptX-Audio
And yes: there ist the below mentioned “faint clicking noise” when selecting aptX-Audio
Regards. and thanks to everyone trying to get these issues ahead. I feel so stupid having given a chance to FP4 after a frustrating single year with FP2 - the least sustainable Cell Phone I have had so far.

1 Like

Not having a device with AptX just reading above detailed explanation and seeing your screen, your device offers Aptx and not AptxHD and therefore for you HD Audio is broken


The Bluetooth option from the headphone called HD-Audio: Qualcomm aptx-Audio. nobody cares which codec is behind it. And nobody has to understand that they ONLY fixed aptx HD.
Fix the Bug!

1 Like

Hi you do realise this is just a user forum, so such demands/commands are inappropriate.

Further: Fairphone do monitor the topics they create and so it is better to add your comment to the their last topic which is the System Update.


Wrong, my devices offer it, I just had to turn it off so that I can listen to music again.
I just wanted to point out the “HD Audio”.


1 Like

Same here. With KOSS Porta Pro Wireless

working bluetooth codecs : SBC, AAC ,aptX HD ,LDAC
not working : aptX

tested with FP4 on Nuber A-125 and Sony WH-1000XM2


Again to anyone here:

From previous posts I installed:

Bluetooth Codec Changer.

It works quite well to quickly switch the CoDec.

You will easily find out what your device is offering.

What is working:
SBC (seen as SD in Bluetooth selection by Android, so what is used when toggle “HD” is off)
AAC (Already the first CoDec seen as “HD” even if this is wrong)
APTX-HD (that is the older high quality one}
What is not working
APTX adapted (that is the newer high quality one)
What is unknown


I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

1 Like