Bluetooth audio bug on Android 12

AptX Adaptive still not working on my FP4 with this latest update . Same symptoms as before when HD audio is enabled. BT device is iFi Audio Go blu. It worked correctly with Android 11 and works correctly with my old OnePlus 6 (Lineage 20 & LDAC). Very frustrating. LDAC on the FP4 works as it should when changed in developer options

Hi there!

Unfortunatley aptx still doesnt work. No Sound on my Beoplay E8. When i Turn Off HD Audio they Work. But the Sound ist horrible.



About aptX: unfortunately aptX does not work for me.

I have a Pioneer SE-MS7BT which can be used with aptX on other devices without any issues. I also tried to remove an re-pair it - no luck. The same behaviour as before: with aptX enabled I only hear a faint constant ticking sound with about two ticks every second as soon I start audio playback. As soon as I disable aptX the headset works fine.

Hi, I’ve done some troubleshooting and can probably explain why some users are reporting the bug as fixed, while others still have issues.

  • The FP4.SP21.B.048.20230215 update does indeed fix aptX HD.
  • It does NOT fix aptX or aptX Adaptive.
  • LDAC works but does NOT get automatically used, see workarounds 2 and 3 below.
  • Bluetooth devices that support aptX or aptX Adaptive will automatically use these over AAC or aptX HD because the FP4 lists these broken ones as higher priority in the bluetooth audio codec list.

Current state of codecs, as of update FP4.SP21.B.048.20230215:

Confirmed working by me:

Confirmed BROKEN by me:
aptX, aptX Adaptive

Confirmed working before the bug was introduced:
SBC, AAC, aptX, aptX HD, aptX Adaptive, LDAC.

If your bluetooth device still can’t play sound with the FP4.SP21.B.048.20230215 update there are 3 workarounds you can try.

Workaround 1:
Free, Automatic each time it connects, Safe

Simply disable “HD audio” like this:

  1. Go to “Settings > Connected Devices”
  2. Click the Gear-icon ( :gear:) next to your device.
  3. Untick “HD audio”.
  4. You should now have working bluetooth audio.

The drawback of this is that you’ll be stuck with SBC (the lowest quality bluetooth codec) until the bug is fixed and you can re-enable “HD audio”.
If you want an option that retains “HD audio” quality with a working codec see Workaround 2.

Workaround 2:
Freemium, Manual switching each time is Free, Automatic switching each time Costs $3.13 USD or €3.49 Euro, Safe

The app “Bluetooth Codec Changer” on the Google Play Store can make the process of switching codec quick and painless, or even automatic if you pay for Premium in the app.

You can get the app here:

You can manually change codec in the app, setup a widget on the home screen, or use the notification to trigger a switch.

If you buy Premium you can setup automatic switching following these steps:

  1. Connect your bluetooth device and confirm it shows up in “Bluetooth Codec Changer”.
  2. Go to “Bluetooth Codec Changer” Settings.
  3. Turn on “Auto Switch”.
  4. Turn on “Background Service”.
  5. Click “Default Codec” and select your desired working codec for this bluetooth device.
  6. Notice that you now have an entry with your selection for this device under “Device Control” which you can delete if you need to remove it or redo it.
  7. You may want to change “Execution Delay” if it doesn’t work reliably, I suggest raising it by 1 second each time until you find a delay that works.
  8. You should now have automatic bluetooth codec switching to whichever codec works best for you, probably aptX HD, LDAC, or AAC, depending on your device.

Don’t forget to remove the devices from “Device Control” in the app once this bug is properly fixed. If you want you can also remove the app once the bug is fixed.

Workaround 3:
Free, Manual each time it connects, Potentially dangerous

You can manually switch the bluetooth codec of your device by using the hidden “Developer options” menu.

To access the “Developer options” menu and do this follow these steps:

  1. Connect your bluetooth device.
  2. Go to “Settings > About phone”.
  3. Scroll down to “Build number” at the bottom and press “Build number” 7 times in a row.
  4. Enter your Pin/Password/Authentication if asked.
  5. You now have “Developer options” available if you go to to “Settings > System > Developer options”.
  6. In “Developer options” search/scroll to “Bluetooth audio codec” and select your desired codec, likely aptX HD, LDAC, or AAC.
  7. You should now have some kind of working “HD audio”.
  8. Repeat this from step 5 EVERY TIME you connect your device again, this setting is NOT remembered between bluetooth uses.

Once the bug is fixed you probably want to go to “Settings > System > Developer options” again and Untick “Use developer options” to re-hide this menu.

Which Bluetooth audio codec is the best? Which should I use?
For reference here is a link with a list of all current Bluetooth audio codecs and their technical performance:

If you want my opinion I would rank the FP4 supported options like this, from “best” to “worst”. My ranking is purely based on sound quality and I don’t care about “latency” which might be important for gaming for example:

LDAC, aptX HD, aptX Adaptive, aptX, AAC, SBC.


Unfortunately the fix does not work for me either. I have Pioneer SE-MJ771BT headphones, that worked fine with android 11.

Just installed the update, but AptX audio is still not working on Sennheiser Momentum 4 headphones. Hope this can be fixed very soon!

Updated yesterday evening but at first testing aptX still does not work (Cambridge Audio earbuds)

Unfortunately my two bluetooth audio devices do only support aptX, not aptX HD :roll_eyes:
So this fix didn’t help for me. Hope this will also be fixed soon. Both devices were connected with aptX under Android 11 before the update and worked flawlessly.

Still not working here. Bluetooth loudspeaker Marshall Stanmore II.

I have the same problem with my Soundcore Liberty 2 Pro. The fix doesn´t fix the problem.
I was really happy when it said that the problem had been fixed. When I then tested it, I could only hold my head and seriously doubted the competence of the people who roll something out.

Dear Fairphone Team,
I have this cell phone because I like to think “green” and I think this device is great. The price for a mid-range device is also okay. But that the software has so many errors, at around €700 for a mobile phone, is simply absurd. The problem with Bluetoot and HD Audio is actually just one of many problems. I expect you to fix the bugs before introducing new features.


The Update does not solve my troubles to pair the right Libretone track air+. After pairing the left one, a message should apear to pair the right one. This is missing. The left is pairing, but I had to turn of the HD-Audio aptX setting. The repairing when I take the left bud out of the charching box is not working. I have to go to bluethooth settings on fairphone 4 and touch on the Libretone track air+ entry. But then the left bud is working. Right one not at all.

1 Like

Tnx. Luckily the Cambridge Audio app provides the option to turn aptX of so thats a simple work around for me. Just wonder what I’m missing out on on sound quality. We’ll hopefully find out after some future update.

Man, it’s so ironic. They remove the headphone jack with the Fairphone 4 and then they break bluetooth audio for a lot of people. :man_facepalming:
Fixing this should be such a huge priority.


Well, this may be the solution for some but not all of us. So I think it is to early to mark this Thread with more than one Bug as solved… My Sennheiser Momentum still only works with SBC…
I hope FP is working on it and I am looking forward to the next sw-uodate (@Yasen_Tomov ?)

1 Like

Hi @gboss,

You are of course correct that this bug is not fully resolved. I think @yvmuell just marked the post as a “Solution” to make it easier for people to find the workarounds until further notice. I am fully expecting Fairphone to fix this bug for all available codecs, anything else would be disappointing.

And speaking of workarounds I believe all generations and versions of the Sennheiser Momentum series support at least SBC, AAC, and aptX, with newer generations in the Momentum series adding support for aptX Adaptive etc as well. As such you should be able to use AAC at the very least which still qualifies as “HD audio” in Android, and perhaps even aptX HD if you have a newer generation Momentum.

Have you tried downloading the Bluetooth Codec Changer app linked in my post, just to check what codecs your Momentums actually support, and trying to switch manually between them? This app will list all available codecs on not only the phone, but also on the bluetooth device so you can try them all and find the best option that’s still working.

For reference here is a handy table containing each bluetooth audio codec and their technical performance which might be helpful in choosing the best one, in case you find that your Sennheiser Momentum headphones support something better than SBC:


Bluetooth aptX HD Audio still not working.
Radio, car radio, headphones remain silent with aptX HD. :frowning:

Fairphone, how do you test? Do you test at all?


1 Like

When you read what FP stated, they exactly did fix this :upside_down_face:

Other improvements

  • A bug that was causing the Bluetooth audio to stop working when the aptX HD codec was selected, has been fixed.

Okay, I’m getting a headache again reading this…

The aptX HD has definitely NOT been fixed.


1 Like

Sennheiser unfortunately not support aptx HD. Only Aptx adaptive.
I do have the True Wireless ones and can chose between AAC or SBC as of now.
My B&W PX7 do work with aptx HD - They support all types of aptx - until adaptive - including HD.

So I hope Fairphone continue to fix the remaining codecs as well.


I see a few people claim that the aptX HD codec still doesn’t work for them.

I would like to know how you’re testing this if you are affected. Either its true that aptX HD codec is still broken for some users, or they are perhaps confusing aptX HD with androids “HD audio” name, or another version of the codec such as regular aptX or aptX Adaptive.

FP4 appears to prioritize the bluetooth audio codecs like this, from 1 being highest priority to 6 being lowest:

  1. aptX Adaptive (Broken)
  2. aptX HD (Working)
  3. aptX (Broken)
  4. AAC (Working)
  5. SBC (Working)
  6. LDAC? (Working. Does not seem to get used automatically?)

If your bluetooth device supports aptX Adaptive it won’t fall back to aptX HD even if aptX Adaptive is broken. If your device supports up to aptX it also won’t fall back to AAC even when aptX is broken. If your device only supports aptX HD as its highest level it should now work out of the box with the latest update. If your device only supports up to AAC or SBC it’ll work out of the box.

See my post here for some workarounds to get working “HD audio” even if your device won’t automatically fall back to a working codec by itself.

I hope this clears up any confusion for users. Of course this bug is not fully resolved until aptX and aptX Adaptive also works correctly. I am fully expecting Fairphone to fix this bug for all available codecs, anything else would be disappointing.

For reference during my troubleshooting I used a number of different bluetooth devices to test. I used both the hidden “Developer options” menu and the Bluetooth Codec Changer app to switch between the available codecs for each device to confirm which ones were working and which ones were broken.

Here are my findings in full:
All testing done with the FP4.SP21.B.048.20230215 update.

Fairphone True Wireless Earbuds
Available Codecs: SBC, AAC
Working: SBC, AAC

Sennheiser Momentum True Wireless 2
Available Codecs: SBC, AAC, aptX
Working: SBC, AAC
Broken: aptX

Bang&Olufsen Beoplay Portal PC/PS
Available Codecs: SBC, AAC, aptX HD, aptX Adaptive
Working: SBC, AAC, aptX HD
Broken: aptX Adaptive

Topping DX3 Pro+
Available Codecs: SBC, AAC, aptX, aptX HD, aptX Adaptive, LDAC
Working: SBC, AAC, aptX HD, LDAC
Broken: aptX, aptX Adaptive
Note: LDAC should’ve been used automatically as the highest quality option, but aptX Adaptive has higher priority in the system and thus necessitates extra steps for switching to LDAC. This should in my opinion either be adjusted or make it simpler to switch to LDAC as the default for devices that support it.

Additional observations
As noted by @RAD above in this post there is sometimes a faint “clicking noise” or perhaps “ticking” when selecting either aptX or aptX Adaptive for me on some devices. Perhaps this is some kind of artifact of the connection attempting to reestablish itself constantly or something. I’ll leave this to the developers to investigate.