Black screen / not booting, but display module works in other phone

Hello there!

TL;DR: My Fairphone 3 has recently gone to sleep and failed to turn on again. I tried removing the battery, waiting, reinserting it, charging, etc. in many different combinations. The battery and display module themselves are not faulty.

When the phone first started not to react to the power button and wake up from sleep, I put it on the charger. The charging LED turned yellow at that point, so I assume the battery was not empty. That matches my expectation of the day’s usage.

Then I took out the battery to reset the phone since I thought it was a software issue. I put the battery back in, but the phone will not boot anymore. The screen stays black, the charging LED also does not light up anymore when I connect it to power.

The only reaction I get from the phone is if I long press the power button, sometimes it vibrates shortly when I do that. It also vibrates when I plug in power while the battery is in.

There was no incident that triggered this defect. I had been using the phone in the morning, put it in my pocket, took it out around noon and it did not turn on.

Things I’ve already tried:

  • I’ve taken out SD + SIM.
  • I’ve tried different chargers, all high quality USB-C.
  • I’ve disassembled the phone and looked at the contacts, they appear not to be damaged. I’ve checked the phone for other visible damage and have found none.
  • I have met up with a local Fairphone Angel who provided me with a brand new display module. That did not work either. I also tried with that new display module and the angel’s own battery, which works in their phone, to no success.
  • My display module works in their phone body. It is obviously not at fault.

Is there anybody here…

  • … who has experienced something similar?
  • … knows how I could maybe get a debug log through USB on my Linux computer, or back up and clear my data before sending in the phone?
  • … has any other helpful tips?

I am grateful for any kind of help. I’ve of course opened a support ticket, but maybe someone from the community knows what’s up or has a smart idea. Thanks :slight_smile:

1 Like

You could try whether the EDL mode still works:

  • Make sure the phone is off. (e.g. by re-seating the battery)
  • Watch the syslog on your computer: sudo dmesg -w
  • Press and hold both volume buttons at the same time.
  • While holding the buttons plug in the USB cable to you computer.

The phone should do a short vibration and a usb device should appear:

usb 1-3: new high-speed USB device number 36 using xhci_hcd
usb 1-3: New USB device found, idVendor=05c6, idProduct=9008, bcdDevice= 0.00
usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-3: Product: QUSB__BULK
usb 1-3: Manufacturer: Qualcomm CDMA Technologies MSM

When it comes up with idProduct=9008 then the phone is in EDL mode.

See Fairphone 3 unbricking for some details on the EDL mode, which could be used to dump (userdata would still be encrypted …) or flash partitions.

1 Like

Dear @_tmp, thanks for taking the time to reply.

I’ve read the unbricking thread and tried to enter EDL, but it does not come up. I’ve tried multiple times to do what you suggested, with the volume buttons. It always registers as 05c6:900e instead :cry:

I am obviously hesitant to perform the disassembly to the mainboard and short the debugging contacts as described by calvofl0, because I assume that would void my warranty. Do you know whether it does? Does the support recommend this procedure?

On a side note: I don’t remember whether I’ve enabled encryption. If I did, is there any way to decrypt the flash image, in case I a) get access to it, e.g. through EDL, and b) still know my PIN?

Probably yes.

Probably no.

Encryption is enabled by default for all Android devices launching with Android 7 or newer.
Unfortunately decrypting the userdata partition will probably not be possible as this would (afaik) require a key which is stored inside the hardware based Trusted Execution Environment.

With a working EDL mode you could try the unbricking approach and hope that you can get the phone to boot again. (Or fastboot TWRP if your bootloader is unlocked)

(Note that any factory reset will also remove all keys from the Trusted Execution Environment)

1 Like

If the device only comes up as 900e no matter what button-combination you try, the only options you have are shorting the testpoints on the mainboard or getting a replacement from Fairphone.
There are no “warranty-void” stickers on the device and the Fairphone is made for taking apart.
I would assume it doesn’t void the warranty so long, as you don’t do any damage.
Your data is encrypted by default on Fairphone OS.
It can only be decrypted on the phone itself, having the PIN is not sufficient.


Thanks @k4y0z! That’s some good info, the phone being encrypted by default. Sadly, that means I can forget my non-backed-up data ;(

I would assume it doesn’t void the warranty

I guess I’ll have to get official confirmation from support anyway for that, since I’d rather not risk getting no replacement on warranty. Better send it in then than risk having to buy a new phone… let’s see what support says, I’ll call them then.

It can only be decrypted on the phone itself, having the PIN is not sufficient.

I was wondering how a 4-digit pin could be secure. Hardware components are obviously the only solution to avoid brute forcing the decryption on a flash image. That’s reassuring to know :+1:

Hey there @_tmp , didn’t see your reply at first. Thank you, too, for the detailed answer on all my questions. Understanding where my data is now and how unlikely I’m going to get it back makes sending in the phone seem less bad now. At least I’ll get a working device that way :wink: Again, I’ll have to see what course of action the Support Team recommends.

Just to be clear, as long as the data isn’t corrupted it’s still possible to get access after unbricking.
That said, unbricking is not a simple procedure and I completely understand if you prefer to send the device in.

2 posts were split to a new topic: FP3 bootet nicht mehr