Black screen for incoming calls

Thank you. This worked for me. On my phone, the ‘phone’ app is called ‘Telephone’ so it took me a while to find it. Cheers.

1 Like

Oh thanks a lot! Mine had that issue. Works fine again
But weird… I didn’t activate that! It worked no more since last update. Thanks again

1 Like

Worked for me as well. Though I also did not change the settings. Thank you for the help!

1 Like

Hi, thanks for this suggestion, works perfectly now!
Just strange because I never checked this “no notifications at all”.
Must have been a bug in the new update… @ you Fairphone guys, please check if with the new update the phone app was automatically not allowed to show notifications anymore. If so, please fix that, thanks!

As this happens to people since june semingly randomly it’s probably not a bug caused by updating.

I was also seeing this same problem (no accept / reject popup on an incoming call, only a small “return to call” button in the lock screen, which would switch to the accept/reject popup and allow accepting the call). For me, the phone notification settings (Settings -> Apps -> Phone -> Notifications) was indeed set to “block”, so switching back to “normal” is probably going to fix this problem (haven’t received any calls so far to test, though).

For me, this behaviour started on a random moment, not correlated to any software update, a few months ago (I can’t remember exactly when, though I think it was later than june). I was running an older FP open beta versions (still the one from the Marshmallow release party at the FP office I think) and thought that was it, but upgrading to the most recent FP open this week did not solve it. Yay for this topic, which (presumably) did solve it :smiley:

I have a FP2, Android 6.01, SecurityPatch 01.02.2018, Kernel Date 11.04.2018

For about a week the screen of my phone is black when an incoming call happens. So I cannot accept the call.
I triggered via “Maintenance” the proximity sensor (several times) - but with no success. I installed a special application to give me the output of that sensor and I get two values: 0cm (when covering the sensor) and 5cm (when not covering the sensor).

Any idea what to do ?

I’ve moved your post here, as it sounds like you have the same issue. The most common way to get things working again is making sure the phone app still has permission to show notifications, as sometimes it seems to lose that.

You should be able to find the relevant settings under ‘Settings > Apps > Phone’.


Yes, thank you. Actually my problems are now gone …

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Borrowing an old topic I found,
so the case with a FP2 is that when the screen is locked / ‘black’ and a call comes you can hear the alarm, but there’s absolutely nothing on the screen indicating it or something you could press to answer the call. If the right side button is pressed the alarm is silenced and you can open the screen, but there’s still nothing. When the caller cuts off the phone shows a missed call.
If a call came when the screen is not locked you have the normal functionalities ie. green button to answer and red to decline.
So, is this a repetition of a case described in the thread copied below and if so, what is the exact setting of permissions for the Phone app or other in the latest FPOS?

Note: The issue is there also after a factory reset. FPOS is up-to-date. On another similar FP2 (we have two) to which FPOS was just recently flashed (back from Open OS) the case does not appear.

Black screen for incoming calls - Help / Fairphone 2 - Fairphone Community Forum

Hello, I’ve opened this old topic and moved your post here.

1 Like

Ok, thanks, but the header shows “solved” all over, so probably not going to raise the interest too much…?

Did you try the “solutions” mentioned above (as fixing proximity sensor and app permissions)?


I have no idea what that proximity sensor might be, but recent findings suggest there’s something wrong with the OS installed.

Fortunately we have two FP2s with the same latest OS builds to compare.

The phone with the issue does NOT have the “Lock screen” options at all in Phone app settings (Phone app - Notifications - Default - Advanced - Lock screen). This phone has been updated with the Updater.

The other which does have the “Lock screen” -settings under Phone app was just recently installed with the “Going Back” from FP Open OS to FPOS -‘option’ from

So, what to do next? Not being able to answer calls is not the only issue with the phone, it also acts sluggish even after factory reset… is there a package to manually reinstall OS?

It’s mentioned e.g. here:

and it’s a sensor at the top of the phone measuring the distance of e.g. your ear while having a phone call (if it thinks the ear to be near it does black out the screen so that you can’t unintentionally touch any icon during a phone call).


Right… ok, I still believe it’s an OS issue as there’s clearly something missing in the menu. Being so, is it something that Fairphone Support should be made aware of, or just accept that ‘something’ went wrong with the updates?

Well, you may open an issue here:

1 Like

OK the first one on the Issues-site I looked at #74 is about app notifications issues after a manual update to Android 10 :smile: Veeeery encouraging indeed.

I’ll give the manual update a shot, the phone is near useless anyway as it is.

Thanks for all the tips so far!

1 Like