Basic out-going phone call settings

When calling someone from my Fairphone 2, my number doesn’t appear on the receiver’s screen. Rather a card saying “private number”. Setting your contact info as private is something yo can do on pretty much every phone, but I haven’t managed to change mine to “public” even after going through pretty much every setting possibility.
I might have missed a pretty obvious setting…

Anybody able to help?


Try this…

  1. Click Phone icon
  2. Click d Dots from Top Right side
  3. Click Serttings
  4. Click Call Settings
  5. Click SUBS Settings
  6. Click GSM Call Settings
  7. Click Additional Settings
  8. Click Caller ID
  9. Set up Show Number

Step 5 to 9 for each SIM


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.