Backup in recovery mode

My Fairphone stopped working this weekend, I get stuck on the blue screen with the Fairphone logo. I will have to do a hard reset, maybe even reinstall. I would like to make a backup but I have two issues:

  1. My phone is encrypted, so what do I need to do to be able to read my backup afterwards? What type of encryption does Android use if you encrypt your phone?

  2. When I try “backup user data” from Recovery mode, I get to about 1/3 and then it gives an error. The calculation of my backup says it will be about 14GB, so I’m asumuing this has to do with the 4GB file size limit of fat32. How should I format my SD card so that I can make a backup? I’ve tried ext2, ext3, ext4 and ntfs, but those aren’t recognized by Android in recovery mode.

Considering your problem, I think my post will probably not help you: I think to do a full backup will not work from recovery mode (i.e. without the help of a backup software). I think it might be possible to to that via ADB, but I don’t know how without doing further searches on the web.

Considering your first question:
I had my phone encrypted, made a full backup using TitaniumBackup Pro to an SD card, wiped the phone, installed TitaniumBackup again, and was able to restore the phone from the backup. Please NB: I restored apps one by one, EXCLUDING (hear me SHOUT :wink: ) all system apps (this includes all Google apps, whcih dig deep into Android). In case of some system apps, I later restored their data (“data only” option in TitaniumBackup) from my SD. I had to re-encrypt afterwards.

I already did a hard reset. And also a downgrade back to 1.6. I’ll keep this in mind if I am faced with the same problem in the future, but I hope not.

See my post over there. The link I posted has quite a good walk through of ADB backup plus extracting your data.


Thanks Stefan, doing the ADB backup now as my phone started acting up again today. So I might need to factory reset and possibly flash it again. But at least this time I was able to make a full backup first. Well, I hope it works, still busy doing it right now.

Unfortunately I am faced with more or less the same problem, except that now my Fairphone still booted, but the same problem I had before I rebooted and got stuck on the blue screen: I keep getting messages that App X, App Y, App Z, etc. has stopped, making my phone completely unusable.

Trying the ADB back up like Stefan suggested, will have to see if it works and I can restore afterwards. But what is the most worrisome is that I get the exact same issues as I did before with 1.8, even though I flashed 1.6 to get passed the blue screen.

Update: I didn’t manage to do a full ADB backup yesterday, I started one and left my phone alone for two hours but when I came back the screen had gone black and pressing the power button didn’t wake it up. Today I tried again, now with the command

adb backup -noshared -all -f /home/dimi/Backup/android-noshared.ab

and it did seem to work, yesterday I tried

adb backup -apk -shared -all -f /home/dimi/Backup/android.ab

which obviously has a lot more to backup. Haven’t tried restoring yet.

1 Like

Apparently this topic is attractive for spammers…