English

Back to Factory Settings

Hi,
at older topics I already have referred about software issues I am struggling with at the Open OS version 16.10.0 and 16.11.0. The issues:

  • I could not download apps from the Google Play Store. I got the message: ‘Google Play Store wurde beendet’ (=has been finished).
  • I could not call the Fairphone updater app and got there a similar message: ‘Fairphone Updater wurde beendet’.
    I tried a lot of different actions to solve these issues, but it didn’t work.

Now I have decided to do a factory reset to start with a clean software. But strange things happened:

  • I have been prepared, that all my private data would have been gone, o.k.!
  • the version I found after reboot: 16.11.0. Nice, already the Open OS as before, so I didn’t need to change myself to the Open OS.
  • at the home screen I found only three apps: ‘Updater’, ‘Benachrichtigungen’ (in English notifications?) and ‘Play Store’.
  • Using the home button I could find some more apps like ‘settings’ and ‘amaze’. So I would be abel to configure the system.
  • going to chose a phone number I found all my addresses, I had before the restore (shouldn’t it be all deleted?!)

disappointing:

  • clicking at the Play Store icon I got the message, I knew already to well!

I didn’t do any other restore, installation or flashing.

My conclusion: The cleanup of old data and issues didn’t work correctly!
Did somebody else have something like this as well? I will try to do the reset to factory settings again, if possible on different ways. And I will report.
Heiner

1 Like

Factory reset only wipes your /data partition.
It seems you had manipulated your /system partition as well (i.e. installed GAPPS). Thus, If you really want to reset your phone you will have to re-flash the whole system (e.g.: follow method 2 here); factory reset will be insufficient.

Hi Gerald,
thank you for your advice! You are right, at the FP2 I had installed Gapps before. Now I have copied the 16.11.0-manual update to the sd-card and than I went into TWRP and flashed the phone with this file and rebooted.
Afterwords all my private data seem to be deleted. Success! Of course, the way I did the update is different from the one suggested, but it’s easier. Is it wrong to do it like this?
After the update I could open the Play Store app and have been asked to configure my Google account. Doing this and denying Google access to my data I have been thrown out.
When I try to start the Play Store, I get the message I already know. So it is the same as before.

Another question:
As I have understood it, the actual update files are all incremental ones. The only not incremental one is the one to go from Open OS back to Fairphone stock GMS. There is no non incremental update file for Open OS v.16.11.0.

I honestly don’t know. I never tried to install an entire OS with TWRP, but I read people doing so. Though, I would only use the ota-update file for that purpose (which I don’t think will give you a complete fresh install, but just an update of your previous installation). I don’t know how TWRP handles files that it should install. With ths manual-userdebug file I am skeptic that it would work in TWRP, because it is supposed to install system.img, boot.img, and recovery.img (beside some modem files) - but how should it install recovery when you are in recovery (i.e. TWRP)? So I am not sure if it works.

What makes me wonder: You say that after the installation you find Google play store. Did you also install opengapps again? Because there should be no such thing from Google on a fresh Open OS install. If you did not also install opengapps I’d say it did not properly install the OS.

I don’t think that the manual-userdebug.zip is an incremental update. It has to be the whole system (it includes, as said, system, boot, and recovery) because it is possible to only flash this version even if you had something else installed earlier.

Of course, I installed open Gapps pico. Because I want to get the Play Store running again!

OK, I just asked because if it was there without opengapps installation it would have been an indicator that the OS installation did not work.

Thank you! I realy don’t know exacly how this works altogether. But your saying sounds quite reasonable. So will do another try, this time like it is recommended!

Another question:
The update instruction says: 'Extract the manual update package (…) by running unzip …
Does this mean, that I have to unzip the fp2…zip file at the desktop to the some place where I have downloaded the file itself? I wasn’t clear about that and therefore a tried the other way.

There’s better instructions here (method 4); same procedure, just different file/OS.
You need to have fastboot set up at your computer to follow this. Have also a look at this:

Yes, that’s quite strange and makes it clear, that the method, I have used, is a wrong one! I did the same again, just to verify and I have got the same result: Play Store did survive and didn’t work still.

Success!!! I have got it! Also the Play Store is gone now. But it took me a lot of time to get it right. The instructions you can read at the forum are sometimes to short. Important steps are left out. Some other instructions are just old and not actual. In some cases I will write a PM to the author to discus and to refresh it.

1 Like

Great go hear you succeeded in getting a clean and fresh installation!

Many instructions in the forum are wikis, so you can edit them or add something if you feel it can be helpful for other users as well :slight_smile:

1 Like

Yes, I know! But I prefer to discus changes with the author for two or three reasons:

  • I might have understood something wrong and I could also write something wrong because my understanding of all this matter isn’t as deep.
  • I have managed to get my Open OS running again, using instructions for the open -, the stock version and finding out myself how it could work. Trying this I got some error messages of course but didn’t brig my phone luckily!
  • As long as only one author is ‘responsible’ for an instruction, it might be represented more clearly.
    The German saying is: ‘Viele Köche verderben den Brei!’

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.