Back to Android

Hi there, I have Ubuntu touch installed on my FP2. My question is now, it’s possible to go back to Android or to the Open version ??? I have already tried the manual flashing script but it didn’t work.

You could have a try with this here …


I have done as explained but after 3 hours the FP2 is still rebooting and the only thing you can see, is the Ubuntu logo. I think it doesn’t work.

“didn’t work” unfortunately isn’t specific enough to be able to help you.

First of all, what operation system do you have on your computer (windows/linux/macOS)?

And when you tried the manual install script, what exactly happened? What were the error messages you got?

As far as I know, at one point the script asks you to type “YES” (because it will erase the data on the phone and you need to confirm that).
And it really has to be an uppercase “YES”, a lowercase “yes” will not work.


My computer runs on Linux. After the terminal has absolved the validation, nothing happened although the FP2 in fastboot mode was connected. Sometimes the program said that “no FP2 found in fastboot mode” but after I started the fastboot mode new and “Do you want to look for a FP2 again: (y)” again nothing happened. The cursor has only jumped in the next line.

The guide reads …

Were you doing this as root or did you try sudo ?

1 Like

I cannot help you more specifically because I’m not good enough with all this but I can tell you that it should be possible because I did it (Ubuntu Touch was too difficult for me to use in its current state).

I may have had problems like needed to change usb cable, stoping neverending reboot by removing the battery.

I did it with the help of infos on these two pages:

Good luck


I made it with the manual flashing script. But I had to use a Windows-Computer.
Maybe I need to become a little bit more familiar with the way Linux works.
Thanks guys.


I have had Ubuntu touch on my phone but it’s just not established enough and too unstable so i want to go back to android. Can someone point me in the direction of a Android installer so I can reinstall android please?

… as pointed out earlier :wink: .

But I have ubuntu installed. But I have done this but now it just won’t boot all it sits on the Fairphone screen?

It means it is still at Fastboot prompt and the boot loader cannot boot the system. Are you sure that you followed the guide and all steps were successfully completed?

Yes to the letter. I can get it into boot loader mode but nothing else !

Ok, next try …

1 Like

Nice one @AnotherElk we are rolling again. Think i’ll leave it this time. I’ve order the F3 so will stick to android on this one.
Thanks again have a good day :+1:t4:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.