Apps vanished after update - damaged phone storage error

After updating my phone to Kola Nut yesterday most of my apps (e.g. paypal, ebay, amazon, runtastic and many more) are not listed in the app launcher any more. So I don’t have access to them any more.

Moreover I am not able to access the widget listings any more as I can’t see this section in the app launcher any more too.

At last I always receive the message “damaged phone storage”. When I click on that notification I am asked to format the SD-card, although there is now SD-card connected to my phone.

Hope somebody can help me with that

The launcher changed a bit: the quick access swipe-from-right-or-left should still work.
To access widgets etc, press the menu button (bottom left, the two window things) or press and hold any empty space.

I did not encounter “damaged phone storage” yet, maybe it’s best to contact support for that.

Thanks for your help, that does solve the widget problem.

But most of my apps are still not listed. When opening settings/apps/downloaded apps most of my previous installed apps are grey and shown as installed on SD-card although I don’t have a SD-card. When trying to move to internal storage I am unable to do cause apps doesn’t exist… Think this problem is related to the damaged phone storage problem.


Could your problem be connected with the “unified storage update”?

  • Did you make this Update before with FPOS 1.6 ?
  • What storage do you NOW have at your phone? Divided into “Internal storage” and “telephone storage”? Or just one partition?
    Cheers, Robert
1 Like

No I didn’t upgrade to the unified storage partition, so I am still using a diverted Internal and telephone storage.

MAYBE that’s the problem!

  • Can anybody else tell us, if it should possible to apply OSv1.8, when the UnifiedStorageUpdate was NOT applied before with OSv1.6?
  • Already anybody tried (exept @goldon goldon)?

Please also see my post about this topic here!
Cheers, Robert

1 Like

If no one has a workable solution for this problem I am going to downgrade to 1.6, install the unified storage update and upgrade to Kola Nut again. Hopefully this will bring my apps back. :sweat:

Please be aware that the storage upgrade will remove all your apps and personal data from your phone.
So you will need to make a thorough backup before doing this.

Yeah, I know, so hopefully apps will be back after the downgrade to 1.6 and prior to the unified storage update :smiley:

Jep, updating to 1.8 without having installed the unified storage partition can cause problems.

Tried to manually install Cherry 1.6, but I am unable to copy the file to my phone as USB connection does not work (not recognized by PC). I also tried to send the file via Bluetooth but I receive an error message on my phone that it’s unable as to receive the file as SD-card is not working.

Any further ideas except setting back to manufacturing / delivering status?



Is there even a “USB options” notification showing up when you connect your FP to your PC?
If there is not then please try some other cables because most likely the cable is not compatible with the FP.

If there is please set your USB mode to “Media Device (MTP)”.

@Tachaddict I tried to connect the phone with the original cable I received when I bought the phone. The option to choose how to connect the phone showed up on the phone and I tried every possible way, but PC always showed me that the phone storage was empty.

In some way I was able to solve the problem. As I am not quite sure what helped I will just tell you what I did.

I just chanced the language of the phone (German to English) and rebooted the phone. After the reboot the message about my damaged storage wasn’t shown anymore and even all my apps were back again. So I made a quick backup because I was able to connect the phone to my computer just as nothing has ever happened, downgraded to Cherry 1.6, installed the unified storage partition and updated to Kola Nut again.

Since this, I didn’t experience any problems so far. So there weren’t much I did, because there haven’t been so many options as my phone didn’t worked properly at this time, except chancing the language to English and reboot the device. :smile:

Thanks for the feedback @goldon sounds very strange.
I’m happy that it worked out for you though.

This topic is now closed. New replies are no longer allowed.