Apps requiring to access device but then not able to perform task

Please help. I’ve never been so frustrated with a phone since the upgrade in softwear!

I currently have the Android 6.0.1 software. I downloaded the Facebook app last week, and now I can’t do anything because the apps don’t seem to talk the softwear at all. I’m sure I’m just being dumb–not tech savvy, and certainly didn’t buy the phone for technical/tinkering related reasons, the environmental/humanitarian issues appealed more.

An app will have a pop up stating: 'Allow [App] to access photos, media and files on your device?'
then: 'Screen overlay detected. To change this permission setting, you first have to turn off the screen overlay from Settings>Apps.

This I can do, but on Apps like Strava or even Facebook you can’t because you get another message by the app stating you need to go into Permission and turn on on Storage. Even when I do that, it pops up with that damn Screen Overlay pop-up!!! I’ve been attempting it for hours.

I’m sure the answer is staring me in the face, but I’ll be damned if I can find it.

Any info, help, or advice would be greatly appreciated because I do love my Fairephone 2, but this is just a nightmare if I can’t post/share/record stuff. I need it because I’m attempting the Yorkshire 3 Peaks Challenge and need apps like Strava so people who make donations can see my training progress. Please help!

Many thanks

Kind regards


You are not the first to have problems with the facebook app.
Remove the facebook app by dragging the app to the top of your phone to the word Uninstall.
Try Tinfoil for facebook, this app might solve your problems.

Thank you, but will Tinfoil work for my other apps? It almost feels like I need to reset my phone because none of them work!

Try uninstalling Facebook, add Tinfoil and reboot your phone.
See what happens then.

Already tried it. Facebook is still deleted/off but all my previous fully-functioning apps just cycle the same damn pop-up mentioned above.

If you go to Settings, About phone (at the bottom of the phone), Updater, on which version are you.

Yeah, 01.07.2017 according to my phone

I think you mentioned the Android security patch level.
Go to settings, then to About phone and then to Updater ( on top of the screen), tap on updater,
What do you see there?
Is it Fairphone OS 17.07.6 ?

screen overlay detected

[quote]List of Apps that can cause this problem (even with permission denied):
ESFile Explorer
Blue Light Filter/Night Light/Brightness controller Apps, e.g.:
Velis auto brightness control
Clean Master[/quote]


I’ve updated it because I wasn’t aware of an update. I normally have a prompt with a circular arrow, but haven’t seen anything like this recently.

After the upgrade, the usual pop-up for an app permission popped up and it doesn’t seem to be come up again once I’ve confirmed it, even with apps like Strava and Instagram.

I think it’s sorted. Sorry for the hassle!

Many thanks for the prompt response!

Kind regards


1 Like

Good that it is solved now. I am glad that I could help you. Don’t hasitate to ask help again when needed.
Every month there is an update, mostly around the fifth.
See fairphone os 17.12.1.
Go to this thread and mark it from ‘normal’ to ‘watching’. You can find this setting under the last message to this thread.
When there is an update this thread will get a message that there is an update.
For an example look at fairphone 17.11.2.

This topic was automatically closed after 182 days. New replies are no longer allowed.