Apps like Whatsapp only notify with wifi :(

Hi. For some reason I don’t get messages from Whatsapp and other apps anymore when I am only connected to 3G. When I enter my home or office, where I have wifi, I suddenly get all the messages. They also show up when I open the app, specifically, even in a place with no wifi.

What do i have to do to get push notifications when I am off wifi?

Thank you!


Only just noticed your post, apologies if this is no longer relevant:
Have you checked under settings > data usage > [menu key*] whether you’ve somehow restricted background data?

*i.e. the left-most of the three hardware keys below the screen

Hi Johannes, thanks for your reply, I’m slow myself in responding!! Unfortunately what you suggest is not the case, any other ideas? Thanks!!

Maybe there is something wrong with Google Cloud Messaging, which is used for push notifications.

Read through this post and check, if GCM is enabled, when you are on 3G.


There is also the possibility that you restricted only the background data of WhatsApp. To check this, go to System Settings -->Data usage–>[name of you SIM] --> WhatsApp and see if the box at the bottom is checked.


ok, thanks everyone!

A post was split to a new topic: Whatsapp only receives notifications on WiFi, but not on 3G/4G