Apps demand android version 5, but FP1 has only older android version

Hi all, I was trying to install several apps demanding android version 5.0 or newer. My FP1U seems to run with an older one (4.4.2 or something). I don’t find a way to update android. Is it possible to do this manually? Fairphone updater says my phone doesn’t need to be updated, so I’m kind of stuck. Is it possible that my phone must continue to run on a three year old android basis?
Thx for some advice! Lothar

Yes unfortunately FP1 is stuck on Android 4. The chipset vendor Mediatek won’t release the code to update to android 5 or higher and even updating to 4.4 is hard without Mediatek’s help. But that’s what the FP team is doing at the moment (see here) and 4.4 is probably the last Android update the FP1 will see.
(Btw. you are probably running 4.2.2 atm.)

Thanks very much, Paul, for explaining! That’s a pity, especially
because a phone’s being sustainable would imply that customers won’t be
tempted to get a new one after a few years to be able to get the newest
software… But I guess in this field as in others Fairphone, as a young
company, has learnt a lot since the release of FP1. (If this problem is
avoidable at all, as far as the chipset market is concerned.)

Which apps are you trying to install? Maybe there are alternatives that run on lower android versions.

It is not. Mobile OSes have been designed with planned obsolescence in mind. Fairphone is doing an outstanding and extraordinary effort: updating the software version of a phone that is not selling nor producing anymore, and without the chipset manufacturer support. That’s AWESOME coming from a company.

I’m happy to have bought the FP2, thus supporting economically the lifecycle of the FP1.


Yes, good idea. I’m looking for alternatives - it’s just for gameplay
recording for the children, so nothing too vital…:wink:

Roboe, that’s interesting, and I’m sure you’re right. I guess, I - like
most people - just don’t know enough about the constraints companys like
Fairphone find themselves under, given the markets as they are. And
thanks for supporting my phone’s lifecycle…:wink:

1 Like

Hello everybody. I am in same situation. I would to install “polar flow” app, but google play say that is not for my phone.
This need android 5.0.
I also need to pair the phone with other devices, by using bluetooth 4.0 LE (also called “smart” ?) but i think that this is available since android 4.4.

The FP1 will soon get an update to Android 4.4.4. The app needs Android 4.3 or higher:

You’ll have to wait a bit until Fairphone releases the update.

Thank you for the info, Stefan. I wish this will happen soon!!!

1 Like

Here is some more info:

5 posts were merged into an existing topic: Longevity vs Obsolescence (software)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.