App Life Cycle function not working


I am writing this post regarding the App Life Cycle function with the FP2 (see here the official article by FP regarding this feature: https://www.fairphone.com/2016/01/07/software-features-fairphone-2/).
Unfortunately is this function currently not working for me, and it never did as I noticed though I am not using all apps constantly (so there should be some apps marked as idle if I don’t use them for more than 1 month). Another FP2 user I met, has no problems with that function and it is working (all updates of the FP2 OS are applied on both of our phones).
Does anyone have an idea how I can activate this feature?

Thanks a lot for your support!

Have a nice day,

I have the same problem. Only after the first month there were some (pre-installed) apps in that section, but a couple of days later they were gone.

In my case this feature has totally gone crazy since I experience the time-reset-to-1970’s-bug on OpenOS. Sometimes every App is idle, every App is active, only the ones I used since the last restart are active and vice versa… But I since this doesn’t really bother me I don’t care about it.

Update about the function (maybe this helps to fix the issue):

The function was for me suddenly available since last week until yesterday when it disappeared again and all apps became active again (and some other time too).
I noticed though one thing: I had many apps open (it seems that flipboard finally triggered the restart of the user surface) and the FP2 user surface somehow crashed and restarted, after that all apps were again on active (though as mentioned before it worked for a bit over a week perfectly and showed everything correctly). I tried then to restart it as well as turn my FP2 off and on again, but now all apps stay active.
Would be great to fix this since I really like the function (when it works :slight_smile: ).

Good luck and thx a lot!

Usually, I never see anything in idle apps, except for two occasions! I’ve had my fp2 for almost a full year now.

Both times it has started and stopped working in the same way.

Last night, my phone hit 15% battery, so I enabled battery saver. It then went into my bag and wasn’t touched for 3 hours as I was bouldering.

When I retrieved it, it was completely dead, no juice left.

Once I got home, I put it on to charge. Usually, it starts straight away, but not this time. This time the power light blinked and it wouldn’t come on for about 10 minutes of charge. Once it came on, idle/active apps had started working!

I figured that a total 0 battery situation had happened and this has allowed something to reset or start properly which didn’t usually happen.

Then, an hour ago, the phone completely froze while using the Facebook app. Screen stayed on, buttons did nothing. I was forced to reset the phone by long pressing on power for 10 secs.

When it came back in, idle apps had stopped working again.

My phone suffers from these lock ups all the time. (Although they don’t usually happen with the screen stuck on) I’m just waiting on a return request to be processed before sending it back. I’m wondering if there is something wrong with it which causes theses lock ups, and the idle apps feature to stop working. I think it’s from one of the first batches (one of the first 17,418)

This could also be (but doesn’t have to be) related to:

(Not sure what the status is now)

1 Like

The crash, possibly yes as it was different to the other crashes I get, but not the idle apps functionality working.

Short update: the app-life-cycle function has been now working for a couple of weeks, even though running the FP update (which usually let the function stop), which is actually great :slight_smile:
Last night though my FP2 had a big workload, updated apps in the background, rebooted (first time in many weeks :slight_smile: ) , and then the function stopped working. It will come back in 1 week since the timer is set to 1 week for this function.

Hint that may help solving the problem: it seems that the FP launcher app (which apparently runs this function), is not in a kind of extra part of the processor but rather running like any other app (hence possibly crashes at some point). Maybe if the FP launcher app runs outside of the part of the processor that contains all other apps, the life-cycle funtion might not stop working (I’m not an IT engineer so I don’t know if that is actually possible but just thought of it).

Besides: loving my FP2 a lot and didnt have any of the problems which some others described (update problems, rebooting, etc). My FP2 runs (beside this one issue here) very smooth and niceley and I’m very happy with it! Great job and congrats to the whole FP2 as well as OS team! :slight_smile:

<3 FP2

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.