"APN settings are not available for this user"


after getting a new SIM-card from my operator, my APN settings are somehow “not available” anymore. When going to “name of access point” I just get a blank page with the following text (in Norwegian) “innstillingene for navn på tilgangspunkt er ikke tilgjengelig for denne brukeren.” Which equals something like “APN settings are not available for this user.” There is no other user on the phone - and I’ve double checked with the “guest user.”

I can, as normally, edit APN-settings by pushing the ±sign, but even though I am saving the settings, there seems to be no change. Likewise, I can push “tilbakestill til standardvalg” (reset to standard settings) - but still, no luck.

I have talked to my operator as the problem emerged (most likely) due to the change of SIM-card. But they don’t understand what’s going on and they have of course never heard of a Fairphone before.

I have even tried to reset the phone to factory settings - which did not help either.

Are there anyone who knows anything about this and could help me?

Thanks in advance.

Ps. Needless to say, the phone was working fine before the change of SIM-card.


Hi Spielmops,

Thank you for the reply. I have already searched the forum before posting. I have gone through everything I could find, and so far (with the obvious possibility that I missed something) I haven’t found anyone with the exact same issue.

I have had to set up the APN settings on my phone before, so I know how to do that. The issue is, as I tried to describe above, that I cannot even access my APN settings.

Please excuse my ignorance if this is a problem that is solved in another post, but I have in any case not managed to find it. If it is obvious to you, could you please redirect me to the correct post or thread?

You can not access your APN-settings, but can you add a new APN?

Thanks for taking the time.

I have seen both of those posts, and even though neither address my problem exactly (I get a blank screen with the text that says that “APN settings are not available for this user”) I have already tried those suggestions. None of them work. There is no “configure card”-line in my SIM Toolkit. And nothing changed after undertaking the shutdown routine.

As I wrote in the first post, I can seemingly add a new APN (the +sign is still there) but upon saving it, nothing happens. The same message (“APN settings are not…”) is still there.

This is how it looks:

ok, that leaves: check your phone with another Sim

Okay! Now I have tried that, and unfortunately - it didn’t work. Even with another sim, the same message is displayed. The sim is from the same operator and is - like my own sim - just about a week old. The other sim works well in another phone.

I have yet not tried my own sim in different phone, but I will try that later today.

Any other suggestions?

You changed the SIM - from another operator to your recent? I would try a SIM from another operator.

Hi again,

finally, I got to try a sim from another operator. With the other sim everything seems to be okay. So the inevitable conclusion is that there is something wrong with my sim. I’ll try talking to the operator - again.

Thank you for the help.

Problem solved:

For some reason, I can push the +sign, write in the APN-settings, and instead of pushing “save” I must push the “backwards”-button (down left on the screen). Then my APN-settings appear and the initial message dissappears.

Does anyone have any idea why this happens?


I am glad to hear you solved your problem!

This I cannot reproduce, for me it also works if I press “save” after making some changes to an APN.

My operator (ice.net) could inform me that they had a similar problem with some Huawei phones.
Strange stuff.

Thanks Pedersen! I had the exact same issue! So annoying and such a meaningless fix…well, it’s working now.

OMG, you just saved my life, God bless you! Everyone, forget about rooting, factory reset, voodoo, JUST PRES BACK BUTTON FROM YOUR PHONE and the APN will be saved automatically! Thanks bro!

You saved my life AND my livingroom window. Plus the phone, offcourse.
Could this happen to be a problem only including the operator ice?
Any way, thank you!!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.