ANT+ adapter built-in?


I couldn´t find it anywhere, but does anybody know if the Fairphone 3 has a built-in ANT+ adapter for connecting heartrate straps and other sensor like that.

Thanks for your help,

1 Like

I quickly installed the ANT+ Heart Rate Monitor app and it is saying that there’s no adapter, either built-in or external available.

ANTtester by Quantrity on the play store suggests that there’s no built-in ANT and no built-in firmware (it says ‘Error :x: Permission > Additional permission > use ANT hardware’ and there’s no permission to grant)

I haven’t got a USB-OTG adapter, so I cannot test that. The ANTtester app suggests that may work.

Apologies I can’t give you a complete answer on that. I’m a little saddened by the lack of ANT+ :frowning:

There is more information on the ANT+ stuff here. Fairphone isn’t mentioned in their product list but it seems that #discuss:fairphone-2 had it with LineageOS

Problem with Garmin gadgets / app and ANT+ support in Fairphone 2


Thank you very much for your answer. I quickly also tried the ANTTester app with the same result --> not built-in ANT+ hardware.

Cheers, Thomas

It does support BLE, which some straps have. Though I did not use mine with FP3 yet, it did work with FP2.

News from Android 10:
Out of curiosity I tested again with the ANT Tester App and YES, it indicates a included Chip of Firmware Version AVN1.0.1B07 and lets one successfully install all the necessary add-ons.
So anyone motivated to test ANT devices, now is the time :wink:
One needs to manually enable the ANT hardware permission though, but the app guides you comfortably.

(sry for necrobombing, but I am just super happy with FP improving their product=)


Whatever that is? :wink:
This thread is not a year old and the information is super exciting for everyone wanting to use this feature.
It’s really great, you let the community know. :grin:

again two years later: I see to have the need of “Ant+” capability for chirping (a part of geocaching, I do since more than ten years).
So I installed a chirp capable app, which directs me to install the right services - with success, but the app ever tells “Ant+ not available”.
So I did a research in this forum, finding this article and your addendum, telling that Android 10 is capable to serve Ant+. I’m now on Android 11 and the mentioned Ant Tester APP (with all installed services) in my case tells (in deutsch) below section “Ant Support Versioninfo” next line “Kein Dienst” - behind that text a “rack-wheel” and a red, closed lock. The same “lock” is shown behind the “Ant Radio Service” line.

Anyone any idea, how to add/activate the obviously needed permission named “ANT-Hardware verwenden”?

Nope - I thought one could enter Apps > Permissions and browse for Ant Hardware category. But while neither the Plugins nor the Radio Service claim to have acquired any additional permissions, Ant Tester App shows “all green” here (except for USB but I didn’t bother installing that).

If I understand you fully, your “ANT Tester” APP does also show anything valuable on first line below section “ANT Support Versionsinfo”, which is “Eingebaute Chip-Firmware:” (in german)?
And you’re further on Android 10 or did you upgrade to Android 11, too?

After having a short discussion with @waldie getting some valuable hints about, Ive decided to contact fairphone support to get final clarity. They finaly answered as follows:

(…)you wanted to know if the Fairphone 3 supports ANT+.

It does not. While the modem chip inside the FP3 is capable os supporting ANT+, this is not implemented in the operating system. ANT+ support has become less common in recent Android versions, as more and more modern devices use Bluetooth LE.


Well. Bold statement it seems. This is from 4.A.0017.3 (A11 Beta flavor)

I have no intention on backtracking how to make it work, but after upgrading to the A11 beta in december 2021 I still have it functioning (don’t really use it though, so full sympathies with the priorities of FP support from my end).

As said, there seems to have been some discontinuities from a frontend side. So in case one really wants to get Ant+ back I imagine that it might work to downgrade to e.g. 3.A.0130, set everything up for Ant+ (especially the permissions), and upgrade back to A11. Fingers crossed.

1 Like