English

Annoying noise canceller active on FP2

Tags: #<Tag:0x00007f05dbfc2ca8>

Today I bought a FP2. As I’m listening classical music quite often using the phone, I was unpleasantly surprised by the FP2: there is a noise canceller active. As soon as there is a soft passage, I can hear the volume try to regulate the background noise. If there is some silence, which occurs quite often in classical music, the sound is completely switched off, it sounds like losing the connection. Is there a way to disable this useless and annoying piece of software? It makes the FP2 unusable for me. It occurs under Android-6 and 7.1.2. The GMS and the open version. As I’ve never encountered this issue on other phones I even wonder if it’s not the piece of hardware that’s causing this…

Richard.

What music player are you using? Mabe installing a different app could help

I used different players, and I tried 4 different flavours of Android, the 18.04.1 and 18.04.3 GMS, the 18.04.1 and 18.10.0 of the OSS version. It looks like it’s something in the hardware. I’ve never heard this before and I have used quite a lot of smartphones. As playing music is very important, I fear this issue is going to be a show stopper for FP2.

It is really annoying to hear the background noise being “regulated” and when there is some silence, it completely switches off the sound. And when it starts again, it makes a short cracking sound. Most people won’t even notice, but unfortunately I do.

Richard.

1 Like

To see if I could replicate this, I listened to some classical music (Dvorak’s The New World) on my FP2, through an amplifier and into big over-ear headphones, and I didn’t hear what you’re describing.

I’m using a player called AIMP, maybe give that one a try? I know for sure it doesn’t exhibit this behaviour, so if it does for you we can be sure the problem lies elsewhere.

1 Like

I just reset the device to factory defaults. But try some very soft recordings. If the noise level is too high is won’t switch off. I use Shure SE535 in ear phones (3-way system). Yesterday I just listened to some radio stations and that’s where I heard it: http://radio.dos.nl/ in the settings you can set AAC or HLS. I used Firefox for this (because of reasons mentioned in the FAQ) I have never had this issue before. If you want I can reinstall the OS and find a track where this occurs. But anyway, I didn’t search for problems, I just heard it and I was quite disappointed, I really love FP2 and OSS. And that site I mentioned is really OK on my Samsung S4 (LineageOS), LG G3 (GMS disabled), LG Stylus2 (GMS disabled), Cubot Manito (GMS disabled). I know mp3 has lower quality than AAC, but it would never switch off background.

OTOH, I think a “normal” user wouldn’t even notice. I’d say: listen to what happens to the weird variations in background noise when you increase or decrease volume when the music is very soft.

I have the strong impression that it’s a hardware issue.

Richard.

1 Like

I assume you don’t have the bluetooth version in use. If so it could be the cause.

No bluetooth. I will try some more tests the coming days, for the moment I’m too busy.

Richard.

The problem has disappeared. I wanted to switch off the device, but ik kept on rebooting so I removed the battery. Since then the sound is ok. I didn’t remove the battery during system updates. Normally I’d expect a complete reset of the device but apparently there was some kind of bitrot somewhere.

I read the “switch off” problem is a known issue with an ugly workaround btw.

2 Likes

Ok, I’m sorry, I have to continue this thread: I installed LineageOS and the problem is still there. But it just happened to be hidden, I thought it had disappeared after having removed the battery.

The issue is this: When playing sound at a normal level, you won’t probably hear it. Just turn down the volume that the music (or speech, as long as there are some form of silence in it) is just above the noise. You will hear the FP switch off and on and during switching off and on there is a lot of cracking distortion. You will also hear the noise being “regulated” like the wind is blowing around the house. This is the reason why I hear it during very soft moments in music.

Other devices absolutely don’t suffer from this.

Richard.

1 Like

I think I’ve replicated your issue. I played Allegri’s Miserere at the lowest possible volume and recorded it through an amp to my PC (which introduced a ton of noise, but the music is audible).

I’ve uploaded a 1 minute sample; the problematic behaviour occurs about 20 seconds in, and a couple of times after that. The end of the sample, which should contain men’s voices, is even almost entirely silent. Aside from the white noise, that is.

I’ve also attached a frequency spectrogram where the dropouts show up clearly in the form of vertical bars.

I have no idea if this is a software or hardware issue. It occurs both in Android and Lineage, but both are based on the same code, so that may not mean anything.

Any people who know more about how these OSes handle sound, or how the FP2’s hardware may be a factor in this?

3 Likes

For future users of search engines: the FP2 is a very nice product, but if you want to listen to high quality music at a low volume, this device will disappoint you. If you listen at medium or high volume, you probably won’t notice it.

R.

I didn’t see your reply before I clicked “send”, Your findings are quite interesting. The main question is whether it’s a hardware or software issue. Maybe it’s a battery saver mechanisme which can be switched off by some sysctl setting. If it’s hardcoded in the SoC than it’s probably not resolvable. The FP2 is super, but for me, using the device to listen to music and speech, this is a very annoying issue (this will be nominated for The Understatement Of The Week)

R.

Use a speech radio station at a low volume. The issue will be audible at the pauses between the words or sentences. I downloaded the sample, and indeed, at 20s it starts, but between 22s and 29s grosso modo you can hear that it switches off and on.

R.

1 Like

It’s definitely not an issue with system volume. I reduced the volume of the same sound file I used earlier in Audacity, after which I played this very quiet file at full volume on my FP2, and the dropouts still occur.

I think it may be appropriate to open an issue in the bugtracker at this point.

1 Like

I wonder if that will resolve the problem. Although I like the FP quite a lot, this bad quality sound issue is really a show stopper for me. I haven’t used it for a week or so, still use my LG. And LineageOS isn’t playing flac files for one or other reason (although that’s not an FP issue). And it’s impossible to switch it off (sic). Yes I know, there are workarounds, but these don’t work.

I simply don’t want workarounds and really very bad sound quality for that price.

For the moment, exit FP2. I’m sorry.

R.

Generally I think this all relates to the used player.

The player I use (Folderplayer) doesn’t play the flac files by itself, it just tells the OS which files it should play. VLC is working, but VLC has its own codecs. It’s an issue that occurs now and then and is often related to ogg and flac files. I’ve been told that mp3 never suffers from this phenomenon. AFAIK the LineageOS I used is capable of playing flac files. The program and the OS apparently do not agree at some point.

R.

Maybe because it’s an early (older) codec which is/was most common. Speaking of compressed music usually first brought .mp3 (mpeg 1 layer 3) into mind. So there may be hardly a device available not being able of playing back such files.

Hm, yep - it tells which codec routine to start, so if the hardware FP2 audio decoder is capable of playing back .flac files it may do so if there is a driver with the OS to call up the routine. Otherwise a software decoder (provided by a player) is needed. You see, VLC can do it and many other players too. (I am using MX Player for all my .flac files).

Actually with Android 7 the hardware video decoder.H264 is not utilized by the OS due to the missing driver support from Google/Qualcomm. So there is only the cpu intense software decoder option by player apps available. A software solution should always work, but may turn out in a higher battery drain and probably lag at some point.

1 Like

The FP2 is capable of playing flac files, the FP OS-es (both GMS and OSS) work. The LineageOS had worked for a while and had suddenly stopped. At that time it was only possible to start a flac file by using a file manager and choose “Open with Folderplayer”. I replaced the uSD and from that moment on it really refused to play flacs. Must be some software issue somewhere.

R.