crashes after android9 upgrade fp2

after upgrading to android9 my fairphone2 is having serial issues. crashes repeatedly. phone is now unusable.
is there any solution to this?
when i tap the “close app” i get about 1 second to try to do something, then it crashes again. and again … it’s impossible to try to do something because this crash report gets on top of whatever i try to do.

1 Like

Welcome to our Community Forum :slight_smile:

Try Settings > Apps > (three dots top right) Show System Apps > Media Storage > Storage > Clear Data

(not sure about the exact wording, I haven’t got Android 9 on the FP2 right now)


is it all data i am supposed to clear, or cache?
i’m a little worried, because i get a warning here that says all files, settings, accounts, databases and so on will be removed permanently…

If you are really in the Media Storage settings, the only data it stores is some kind of “table of (media) contents” on your phone, not the media itself. If you look at how much data it is, it might only be single or double digit MBs.

Once it is cleared, Media Storage will start to build up this table of contents again, this can take a few minutes. But the error message should be gone immediately.


Had the same problem today after upgrading my FP2; that troubleshooting above mentioned really works; many thanks to urs_lesse - here the path on a FP2 with German UI:

Einstellungen > Apps & Benachrichtigungen > Alle xy Apps anzeigen > (select three dots top right) > Systemprozesse anzeigen > (scroll down to: “Medienspeicher” and select) > select “Speicher” > “Speicherinhalt löschen” and then “Cache leeren”

Eventually make a restart… that’s all. Now my FP2 runs as stable as before… :wink:


After updating to Android 9, the phone still worked, but all media libraries and Spotify triggered this same message. I could not delete or download any data. The problem was resolved using the method described by urs_lesse and all files are still there and can be called up.


I’ve had the same issue - absolutely infuriating! The fix above has worked. Until doing that I couldn’t see any of my photos, but they’ve now reappeared.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.