Android 9 on FP2 unstable?

Hi, I am using a FP2 for some month now without mobile data, just SIM for calls and Wlan.
I got the upgrade to Fairphone OS 21.10.0-rel.2 (thats android 9, right?) and I am experiencing software lags: Sometimes, when someone is calling, the phone does not react to physical button press. Somtimes I have to press the on-button several times, to turn on the screen.
Sometimes the screen turns to a rgb-noise for some seconds.
I wasn’t able yet to provoke this behaviour, so i cannot provide a guide how to reproduce it.

For now just wanted to ask if you are or was experiencing the same problem and wheter its a hardware problem or software bug or something else.

One thing I did recently was to open it completely and clean all the contacsts. Cannot say yet if that did help to reduce the lags.

Is it like the problem described in this thread?

Hello, also using an FP2 with the OS 21.10.0 installed manually via adb (
I actually experience my phone being unstable with it, some applications are freezing and crashing almost everytime I use them, and some others not. For instance: Fairmail and Lexica do crash.
Sometimes system apps crash like “interface” or “fairphone launcher”, but less frequently.
Before that, I tried installing /e/OS then LineageOS (android 10), but it was really very very instable, and I decided to move to FP open OS / android 9, which is a little better.
I’m also wondering whether this is a software problem, or if it may be linked to some memory wear, as I really hacked my phone with new OSes many times since I purchased it 6 years ago.
I might be reinstalling some older standard OS to check, and I’ll let you know here.

Did you switch from Fairphone open OS to Fairphone OS or vice versa? If not, using the manual switcher might cause the issues, as a manual installation should not be done using the switcher, unless you want to switch between FPOS and FPOOS.
In case you used and use FPOS please see here

For FPOOS please see here

Edit: my FP2 runs quite well with LOS (currently 18.1) + Gapps Pico.

1 Like

I used FP OS and switched to FP open OS. I’m not sure getting your point.

that was not clear to me from your explanation and there was confusion in the past of how and when to use the manual switcher. So no issue for you as you confirmed you actually switched from FPOS to FPOOS.
Still I dont see such issues that frequently on my FP2 irrespective of which OS used, so I actually doubt that an older Version would help a lot. You can try to run in #dic:safemode to see if it still occurs, if not an app might be the cause. Also SD or SIM cards can become faulty and cause instability.


Is it like the problem described in this thread?

Hi, I’m not sure, but it could be. After removing and carefully cleaning and reputting all the modules, FP2 runs much better. Maybe it solved all the problems, but at least most of them.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.