Android 6.0 is now available (Fairphone OS 17.04.8)

If you have Open OS you probably have to switch to FP OS Lollipop anyway before being able to upgrade - unless you wait for the Open OS Marshmallow Upgrade.

The upgrade will fail if you don’t have the official Google App and if your device is “modified” - and Open OS is full of modifications (root, TWRP, no GAPPS).

Just did the Update and so far all is well.
Good Work!


Not working for me, downloading great, but failure when reboot :frowning: (I have the latest version of the app)

Where did the “peace of mind” thing go ?


Happened to me also on the first try. I downloaded it again and reinstalled it again. Then it worked


I’ve tried 4 o 5 times in the last 2 hours, and after the downloading and the reboot, the installation fails saying “unexpected contents”. I’ve cleaned the cache partition, and the Updater app data and cache data, but every time I try it ends the same. Anyone else out there seeing the same issue?

Failing for me on a rooted phone, I get an error when verifying the sideload. Says that I has unexpected contents. Problem is release-keys. Anyone else?

What does the error message say?

See here.

Did you do any modifications to the system before upgrading?

You can’t do this upgrade with a rooted phone.

1 Like

6 posts were split to a new topic: Is it possible to upgrade a rooted phone without unrooting?

The updater crashed without any explanations several times, but i found that the problem was that i did not have enough space. After removing some files it works.


Thanks Paul, yes, I rooted the phone a couple of moths ago but then (in theory) unrooted it. It seems that I did not do it correctly, if anyone has a hint to do it right please share. Thanks!

hi, new FP2 arrived today but no android 6 update visible in updater app yet - OS 1.13.0 given as up to date. WiFi connection all good.

The easiest way is probably to reinstall your current OS before upgrading. Go to the advanced mode in the Updater App, there you’ll find that option.

You’ll have to update the updater app through the play store.

1 Like

ah, got it. thought I had already got all my apps up to date. Obviously not, cheers!

1 Like

I had the same experience, just be patient. I was going to post about it here as well but as I was writing it suddenly the update appeared on my FP :wink:


“Error in the Heading section” or something like that?
Shell I try again?

Thanks a lot for your kind help Paul. What I did to unroot was precisely that, however I’m willing to try it again but in the Updater’s Advanced Mode I just see one entry for 17.04.8, and nothing for 1.13.0

One question, if I follow the full update procedure whenever the binary file is available, I will lose my user data, or it is safe on this regard?

Full update and binary are two different things.
With the full update, I’ve done all the updates over the last past months and never lost anything.

That’s what I’d do. Was it maybe “footer is wrong”? That sometimes happens if something went wrong during the download of the file.

Oh sorry. You could try a manual "up"date, but I can’t find the page with the files on the support pages atm, they seem to get revamped right now.

I don’t know what yo mean by that exactly, but usually updating doesn’t erase any data unless you switch between FP OS and Open OS.

Loving the new startup animation and “Change is in your hands”!! :smiley: