English

Android 10: no fingerprint for unlock

Ok, then my assumption was wrong and these problems seem unrelated to the update method.

Hi kosmar,

the option is not listed under Settings > Security > Screen lock, that’s true. But under “Fingerprint” right below it says

In addition to unlocking your phone, you can also use your fingerprint to authorise purchases and app access.

Hope this helps.

Best wishes,
Thomas

2 Likes

I know, but how do you set it up to enjoy those promised features?

‘learn more’ doesn’t work either, does is?

IMHO it just works once you have set up one or more fingers.

I have five fingers already. Will try.

deleted one, reset one. no change.

does it work with yours?

had to delete all. Still can’t select it as method, but it works. very misleading, as I now cannot remove it as unlock method either.

I had an issue where the fingerprint would not work for the lock screen but did for all the apps, so the phone hasn’t forgotten about the fingerprints and the fingerprint sensor was still working.

After rebooting it started working again.

1 Like

Similiar for me except rebooting doesn’t fix the problem. I updated a few days ago (OTA) and I’m pretty sure it still worked at some point today and yesterday. Now it won’t, deleted my fingerprints and added them again but on the lockscreen the fingerprint sensor won’t work (or even trigger a vibration). Any options left to debug this issue?

Now it works again - I removed all fingerprints again, rebooted, added fingerprints. :slightly_smiling_face:
It looks like it’s important to reboot without any registered fingerprints in the settings.

4 Likes

And since yesterday fingerprint unlock is gone once more. I didn’t try to restore functionality yet. Yes, it’s annoying. :slightly_frowning_face:

I experience the same problem. Fingerprints are still stored and functioned well until recently. But now they won’t do the trick for unlocking the phone. Also for me: deleting the prints, rebooting and re-registering worked, but after a while they stop working…

My guess is, that it has something to do with failed attempts: if you have the phone in your pocket it may try to unlock often when it slightly moves inside. Is it possible that there is not only a counter for each individual attempt to unlock, but also an overall count?

1 Like

I don’t believe there’s this type of counter. But every reboot disables fingerprint unlocking for me, even “controlled” manual reboots.

but after a while they stop working
Android 10 on the Fairphone tends to crash from time to time (causing a reboot). This is a known issue right now. Does this might be what you experienced?

Since the last update, this problem is gone with my FP3+.
Only that the fingerprint sensor often does not detect properly and I have to unlock via different mode.

When did this update happen? Didn’t got any update in November for my FP3 (non-plus).

I was referring to the last one a few weeks ago, I believe it was Oct 22?

1 Like

Thx, I just wanted to make sure there wasn’t a FP3+ exclusive update already I missed (By the way, here’s a list of all updates: ✏ FP3 OS updates - changelog & OTA links). October update didn’t fix anything for me.

Hello everyone,
maybe you know this already but you can unlock your FP3 with fingerprint by default. Maybe it came with an update.

I was having this issue after updating my system to Android 10, but the “fingerprint” option under settings → security wasn’t even visible, and it did not register anything at all with the fingerprint reader, not even an inaccurate print.

While in settings → security, I accidentally clicked on “security update”, and apparently that was not up to date, so I updated it and now my fingerprint reader works as perfectly as it did before.

Perhaps check that all your updates are finished? Mine just needed to restart, but hadn’t given me any push notifications about it so I didn’t know.

2 Likes

Since acquiring my FP3+ in September I’ve never been able to use the fingerprint scanner / reader satisfactorily, but I’ve often had problems with other fingerprint scanners so I wasn’t surprised.

I had entertained the idea of trying the adhesive tape trick but never got round to it. However since updating to the latest 10 version 8901.3.A.0107.20210513 it’s been working perfectly. I can’t be sure this is due to the update but it seems so. No problems with reboots either. Very short taps work fine.

2 Likes

Hello!

Not sure I have the same issue as yours, but here’s mine: if I don’t use the fingerprint immediately after the boot, I can’t use the fingerprint anymore to unlock the screen.

Here is what happens:

  • Boot the phone and wait until the lock screen appears (the one with the clock, by default)
  • Either unlock the phone using the pin (and not with the fingerprint) or wait until the screen turns off
  • When you try to unlock the phone later, you can’t use the fingerprint method (nothing happens if you touch the sensor) and you must use the pin (or other method) to unlock

Now reboot and use the fingerprint immediately when the first lock screen appears: it asks you to type your pin (as it’s the first unlock since reboot, that’s normal) but then you can use the fingerprint every time you want to unlock the phone.

Has this issue already been seen?