After upgrade to FP3 ...3.A.0045.20200905 MQTT based app says 'network unreachable'

after upgrading from FP3 A.0033 to A.0045 my MQTT based apps won’t run any longer via mobile data. WLAN works still fine. Termux says on ping: Network is unreachable. Is it anyhow possible to downgrade that version?



what MQTT based apps do you have? I thought MQTT was for IoT?
Anyway: have you tried to manually re-add your internet APN?

Best wishes,


Hi Thomas,

thanks for your quick answer.

I wrote the app myself, using Android Studio. It is running on a couple
phones, since almost 2 years and helps to supervise some waterworks.
It’s running on my wifes phone as well but she has yet an older build of
Android 10 installed.

I also can simulate it using Termux and try to ping the brokers IP. Via
WLAN all works fine, via mobile data it says “Network is unreachable”.
Interesting is, that email or signal/telegram is running.

“manually re-add my internet APN” - how can I do that?

Best regards


1 Like

Hi Roland,

you can do that at Settings > Network & Internet > Mobile Network > Advanced > Access Point Names. Your carrier should have the correct current settings somewhere on its website.

Good luck!


Hi Thomas,

I 've done it yesterday. Klarmobil sent me the new data. It worked.
Thank you.



Ah, good to know. I had some strange connectivity issues myself. Some missing functionality in certain apps. I then found that had put me on an IPv6 APN (which some app obviously cannot cope with yet). After switching back to DS everything worked like a charm again …

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.