After Updating to 1.8.7 - Problems with GSM Notifications

After updating my FP1 to 1.8.7 and installing the Google Apps, I deactivated some of them as I did before.
I deactivated google+, googleFotos and so on.
Now I doesn’t get notification for my crypto messanger app “surespot”. They are using the old Google gsm for Notifications.
How can I check if this is still there? Other apps like “K-9 Mail” still can send notifications.

I tried to reinstall the google apps 4 times, but nothing changed.

Install any app from the play store. That should reactivate gsm.

1 Like

Hi Lya,

the same often happens with TextSecure after an update, too. In TextSecure, the problem is solved if you unregister and then reregister for push messages once. (No reinstallation needed.) TextSecure’s problem is also caused by GCM, so I’m pretty confident that an analogous procedure will help you with Surespot.

I hesitated to try this one because the phone protests insufficient storage space when I tried to update several apps but this solution worked.
After reinstalling surespot and importing my profile data it works well again.

thank you

Surespot doesn’t have a feature to re-register for notifications.
I tried to disable notifications, reboot, enable notifications, reboot. But this doesn’t work.

Finally I reinstalled the app. This one worked for surespot. You must
export your account data before de-installation and reimport after new
installation and then everything works fine again.

If you have a First Edition Fairphone (FP1) from late-2013/early-2014, have you done the Storage Upgrade? This would normally solve Insufficient Storage errors.

@Lya following up from @stefan, yes the “storage upgrade” typically fixes the insufficient storage error. You can check: System settings, Storage.

  • If you see Internal and SD Card, then you have the “storage upgrade.”

  • If you see Internal, Phone, and SD Card, then you are running an outdated version of Fairphone OS. A more recent version addressed the issue of insufficient app storage.

Does that help?

1 Like

@Stefan and @heyandy889 No, I didn’t made the Storage Upgrade.
Now, I don’t see a chance to make it. I cant’t install a backup app like any other app.
Internal Storage says it has 94 MB available, Phone Storage says there is 8,92 GB free Storage… but still insufficiant…
I had set Default Installation Path to Phone Storage and transferred most of the apps to phone storage.

Is there a way to make a backup manualy via USB data tansfer?

Well, if you only want to backup photos, music and videos, you can just connect your phone via USB and drag and drop them to a folder on your computer.

I’m afraid, backing up app data won’t be so easy without a dedicated app. App data is in most cases stored in /data/data. You need a root explorer like Amaze File Manager to access these files. Here are some steps you could follow to backup your app data (no guarantee from my side though):

  1. Download and install Amazed File Manager.
  2. Go to Amaze, slide in from the left side and go to Settings. There scroll down and toggle the switch of “Root Explorer” to ON. You will now be able to see all system files.
  3. Slide in from the left side again and press “Root”.
  4. Go to the directory /data/data. You will see a lot of folders containing the data of your apps.
  5. Press long on any of the folders until it gets selected and then press the three dots in the upper right corner. Press “Select all” (Alles Auswählen in my screenshot).
  6. Press the copy-icon.
  7. Navigate to your SD-card (“External Storage”) and paste the files there. If you don’t have a SD-card, go to a folder, which you can see on your computer, paste the files there and move them to your computer afterwards.
  8. Your app data is save now. When restoring the files, it is advised to refrain from restoring system app data (like e.g. the folders starting with “”, “” or “com.mediatek”).

Here is an article by Fairphone Support about the matter, most of it however presumes you can install apps.

I hope this helps. :slight_smile: If you have questions, don’t hesitate to ask!

1 Like

I solved my urgent insufficient storage problem, which doesn’t let me update/install anything.
Luckily I had the app TotalCommander. I fount several giant log files in /data/log_other_mode/
I deleted them and at last I could update my apps… and install Backup&Restore

At weekend I plan to do the quest to install the storage Upgrade for 1.7.8 :smiley:

1 Like