After puting an micro-sd-card into my phone my phone memory isn't working anymore

I tried to put an micro-sd-card into my phone. I accepted to formate the card and tried to copy everthing possible to the card. Afterwards there was no data on the card and all my photos from my phone were gone.

The problem is, that my complete phone memory isn’t working anymore. I can not take photos, listening to music, open photos people send me, neither downloading apps is working. What can I do? If I put the card out of the phone nothing changes.

Would it work to reset the phone? Or would I destroy it by doing that?

Please help me, I can’t take photos of my dog anymore for four days already! :frowning: :smiley:

Could you precise which phone you have? FP1, FP2 or FP3?
I’ll suppose you have a FP3 turning under android 10. In this case, :warning: Don’t format your SD card as internal storage! As you noticed, it will break many features. See here for instance: Android 10 - MicroSD as phone storage. You can also have a look at the #sdcardguide for more details. Formatting it as external storage will cause you less trouble.
First, try taking your SD card away and see if your phone works as expected.
If no, I’m afraid you’ll have to reset the phone.
In both cases, once the card is inserted, you can reformat your card as external storage by going in Settings→Storage→SD card→Three dots menu→Storage settings→Format as external
You can also format it from a computer (e.g with GParted). In this case, format it as exFAT.
Don’t hesitate to ask further questions if you have any or if I wasn’t clear :slight_smile:

Edit: Typo


Thank you!!! I managed to reformat the card and everything works fine again!
Thank you for your help! :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.