After connecting the FP2 to the PC, there is no choice anymore for mounting

Hi All
As it described above, if i connect the FP2 with the USB port i cant anymore chose for mounting the SD card, it only charge the Batterie.
How can i change this?
Any other with this problem?

Thank you for your help!

lg ivi

: found this hint for solution;

But, in my case, the option is not available ;(

see here;

Hi ! :slightly_smiling:
I think we have the same problem and i have posted a topic in the same time. So i put my topic here with your’s and i put a link in my topic to your’s.
I hope someone will help us !

J’ai reçu mon Fairphone avec grand plaisir, toutefois j’ai un problème. Je vais essayer d’être le plus clair possible.
Tout d’abord mon téléphone n’est pas reconnu par mon ordinateur. J’ai trouvé des personnes qui solutionnaient ce problème en adaptant les paramètres dans “connexion USB à l’ordinateur”. Mon problème est donc le suivant :
refuse de me faire accéder au dossier “Connexion USB à l’ordinateur”. Je peux le voir mais si je clique dessus, rien ne se passe, aucun moyen de rentrer dedans. Je ne peux donc pas configurer ces paramètres. J’espère que je suis clair et je remercie beaucoup tous ceux qui pourront m’aider!

I received my Fairphone with great pleasure, but I have a problem. I’ll try to be as clear as possible.
First, my phone not recognized by my computer. So I found people who asking to this problem by adjusting the settings in “USB connection to the computer.” But my problem is the following:
It refuses to let me access the folder “USB connection to the computer.” I can see it but if I click on it, nothing happens, no way to get into it. So I can not configure these settings. I hope I’m clear and I thank all those who can help me! Sorry about my bad english."

1 Like

aver you give a try for the link a postet?

Does the following work?

  • Connect the FP2 to PC via a standard (Data-)USB-Cable
  • Unlock the phone, swipe down from top. There should be a notification, saying some thing like “Tap to select USB mode”.
  • Tap it and select your desired USB mode.
  • On Windows, it takes a looooong time to install the necessary drivers… :frowning:

Possible error causes:

  • USB-Cable is no Data-Cable. To exclude this, just try another device with the same cable
  • Drivers not installed. You’ll maybe have to have Internet access for downloading the drivers
1 Like

Note: This is not a popup notification. You must slide from the top down to get to the notifications panel.
But I guess when the button in the storage settings is greyed-out the notification won’t appear either. My guess is also it’s a bud cable - either not a data cable or a broken cable.

1 Like

Thank you for your help !
As Paulkreuzer said, the notification appaers nowhere…
I have to go buy a new cable tomorrow so i will try with it.
If it doesn’t work, how can i install the drivers?

Hi all
Like here , no noficatin and my cable is sure ok , becos 1 weak a go I could send files through that to the PC…
I changed my launcher, and I frizzed some google app. But I make everything back and it does still not work…
anybody a idear which system app is in charge to do the connecting part with mounting the SD card?
Greetings ivi

:fr: En fait, ce que Paul a décrit, c’est que ce n’est pas une notification mais que tu dois " la chercher " en glissant du haut de ton écran vers le bas. Quand tu fais cela, tu devrais voir un onglet qui te propose de changer les options USB et si tu cliques là-dessus, tu peux les changer normalement.

Sinon, juste pour être sûre, tu es sur quel système : Linux, Windows, le fruit ? Il se peut qu’il te faut d’autres pilotes…

:de: Von deinem Screenshot her glaube ich mal, dass du deutsch sprichst. Daher also die Frage: Hast du mal verschiedene USB-Ports ausprobiert? Bei mir funktioniert das mounten auch nur ĂĽber den vom Laptop aber z.B. nicht ĂĽber die der docking station.
Ansonsten könnten dir einfach ein paar Treiber fehlen. Das kommt aber auf dein Betriebssystem an. Bist du auf Linux, Windows, dem Obst?

:gb: @ivi and @Math_Ramb: You may have a look at Fairphone 2 and Linux [resolved] and ADB on FP2? [Solved: Uncheck all boxes in USB connection popup] as well.

Merci dir :wink:
Nein es kann kein Treiber Problem sein, da vor 5 tagen alles ging. Ich vermute es liegt an einer Google APP die ich per titanium APP eingefroren habe…
Daher meine Frage, welche system APP ist fĂĽr die Verbindung des FP2 per USB mit dem PC verantwortlich?
LG ivi

Hi all
Tomorrow i saw the usb cable was plugged wrong :flushed:
Sorry guys, in my case this was the reason. So for me the problem is solved…

I thank you very much for all the warm help, really, its a great community here :clap:

Greetings ivi

1 Like

FR Bonjour tout le monde!
J’ai acheté un nouveau câble ce matin comme prévu.
Ca fonctionne enfin ! La notification, qui n’apparaissait pas avant, est arrivée. C’était donc moi aussi un problème de câble.
Je précise pour les prochains qui auraient ce problème que mon ancien câble chargeait quand même mon téléphone mais ne faisait pas apparaitre la notification de Connexion USB. Ainsi, peut-être que si d’autres ont ce problème, la première chose à faire est surement d’essayer un nouveau câble pour vérifier.
En tout cas je suis très content et je remercie tous ceux qui ont participé à ce sujet ! C’est une jolie communauté ! Merci tout le monde.

EN Hello everybody!
I bought a new cable this morning as planned. It works finally! The notification, which did not appear before, has arrived. So it was a cable problem too like ivi.
I specify for the next persons that would have the same problem that my old cable still charged my phone but the notification was not here. So maybe if others have this problem, the first thing to do is probably to try a new cable to check.
Anyway I am very happy and I thank all those who participated in it! It’s a lovely community!
Thank you everyone!