"Add to calender" does not work anymore

@DjDas has the same problem:

It seems that Add to calendar has stopped working. It worked before and I can’t find a reason why it shouldn’t work anymore. Could you please verify?

Steps to reproduce:

  1. Install “Add to Calendar” (1.0 or 1.1 Neither works)
  2. Download an .ics-file, for example from that page: http://kalender.kjwien.at (You have to press the little calender icon next to an entry).
  3. Open it and select “Add to calendar” from the window that opens.
  4. Nothing happens (the calendar should open, with the option to save the new calendar entry. This has worked before.)

PS: I’m trying this on Fennec F-Droid (Firefox Mobile) 39.xx. The browser seems a bit unresponsive after trying the import.

Here is my log:

[quote]08-05 13:10:17.864 I/ActivityManager(514): START u0 {act=android.intent.action.VIEW dat=file:///storage/emulated/0/Download/download(18).ics typ=text/calendar flg=0x3000000 cmp=org.dgtale.icsimport/.MainActivity} from pid 4388
08-05 13:10:17.960 W/System.err(3669): at org.dgtale.icsimport.MainActivity.onCreate(MainActivity.java:53)
08-05 13:14:03.354 I/ActivityManager(514): START u0 {act=android.intent.action.VIEW dat=file:///storage/emulated/0/Download/download(18).ics typ=text/calendar cmp=android/com.android.internal.app.ResolverActivity} from pid 6648
08-05 13:14:04.376 I/ActivityManager(514): START u0 {act=android.intent.action.VIEW dat=file:///storage/emulated/0/Download/download(18).ics typ=text/calendar flg=0x3000000 cmp=org.dgtale.icsimport/.MainActivity} from pid 4388
08-05 13:14:04.485 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl.parse(CalendarParserImpl.java:148)
08-05 13:14:04.485 W/System.err(3669): at net.fortuna.ical4j.data.CalendarBuilder.build(CalendarBuilder.java:210)
08-05 13:14:04.485 W/System.err(3669): at net.fortuna.ical4j.data.CalendarBuilder.build(CalendarBuilder.java:191)
08-05 13:14:04.485 W/System.err(3669): at net.fortuna.ical4j.data.CalendarBuilder.build(CalendarBuilder.java:179)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarBuilder$ContentHandlerImpl.startProperty(CalendarBuilder.java:346)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$PropertyParser.parse(CalendarParserImpl.java:211)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$PropertyParser.access$1(CalendarParserImpl.java:200)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$PropertyListParser.parse(CalendarParserImpl.java:178)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$ComponentParser.parse(CalendarParserImpl.java:390)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$ComponentParser.access$1(CalendarParserImpl.java:376)
08-05 13:14:04.487 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl$PropertyListParser.parse(CalendarParserImpl.java:175)
08-05 13:14:04.488 W/System.err(3669): at net.fortuna.ical4j.data.CalendarParserImpl.parse(CalendarParserImpl.java:125)[/quote]

PS: I found this bug report on Github, which seems to deal with the same problem. Unfortunately the developer does not have access to an Android 4.2.2 phone.

1 Like

I have the feeling (NB!) that this is related to a path/storage error. Can you revert to an (earlier) backup of the respective calender files? If so, from my experience on desktops (NB!!!), my approach would be to delete the file in question above (download(18).ics, ppbl), see what happens, and if the app crashes revert to the backup.

Also, you could try to rename the file to download.ics, and see what happens.

Sorry, I am ppbly not of much help here, I am a real android (and linux) noob - but that’s what I would try, in all noobness.

1 Like

I wrote the first post in a hurry, I’m gonna add the additional info, which I had posted originally in the beta tester forum.

I followed your advice, @humorkritik, and deleted the brackets. Same result. Then I scrolled down and found an older calendar file named “calendar(17).ics”, which works. So it is definitely not the brackets!

In the Github thread the OP states that it works with Chrome. Can somebody confirm (I don’t have Google Play, so no Chrome either)?

Edit: I could narrow it down. The issue started with ics-files downloaded on the 13th of July. The same day Fennec F-Droid 39.0.1 was released. It maybe that the issue started with that particular version.

Edit2: ics-files from kalender.kjwien.at work, if they are not in the past, but in the future. ICS files from scotty.oebb.at (Austrian railways) don’t work, even if in the future (you have to enter two stations, click “Verbindungen suchen” (the red button), then select a connection and choose “Kalenderexport”).


Did you try the stock browser as well? Or dl the file and importing it via the calendar app?

Stock browser doesn’t solve the problem. How can I import it via the calendar app? That is why I need to use “Add to calender”, because the native calendar app, doesn’t provide such a functionality…