ADB says "no permission" after upgrade to 1.8.5

After updating my FP to 1.8.5 and connecting my device to USB in debugging and USB-storage mode on Linux the command

>adb devices 

puts out

List of devices attached
????????????    no permissions

changing to MTP-mode the device is recognized

>adb devices 
List of devices attached 
4010914717      device

Before this upgrade I’m quite sure that the adb connection worked in storage-mode.
Is this a bug or a feature :wink:

I’ll hope you’ll get an answer here as well, but maybe you should cross-reference your post in the >130 messages thread on the 1.8.5 update to increase visibility. :wink:

Did you enable USB debugging? For me ADB works well after update to 1.8.5.


I think the problem may be the storage-mode.
which have you enabled?
If you have MTP-Mode enabled please switch to storage-mode and try adb again.
Let me know if it works.
Which OS do you use with adb?

I usually start the adb daemon as root which is probably bad practise, but I was always too lazy to properly set everything up. I think I originally started doing

sudo adb start-server


adb devices

gave me this exact

????????????    no permissions

output when not executed as root.

Now when I tried starting the daemon with my normal user account and version 1.8.5 on my phone, adb devices correctly listed my phone - as long as it’s in MTP mode :stuck_out_tongue:
So, in some way, I can reproduce @infos’ problem. sudo adb start-server still works with both storage modes though. Oh well.

1 Like

so, it seems to be rather a bug than a feature, no :stuck_out_tongue_winking_eye:

I did a quick search on Google and found this, which looked reasonable to me. Does it help?

1 Like

Yes, I mean this will possibly solve the problem such as @haffenloher solution.

But I wonder why before the upgrade adb worked without this workarounds.

I my opinion it must be a user right management problem on this Android version using usb in storage mode.
While using mtp mode it works as desired.
As far as I know mtp depends also on udev rules.

So for me it remains a bug :wink:

I wonder: Have you done the Storage Upgrade? Then you will notice that your internal storage is not exposed anymore in storage mode (only in MTP mode!). In this case, it is not a bug, but a side effect of the Unified Storage Partition.

If “Storage Upgrade” means changing the sd card, the answer is no.
I made a normal update with the FP update tool.

But I wonder if this behaviour you described is a new feature of the 1.8.5 version, i.e. is the storage mode deprecated?

The storage upgrade unifies the “internal storage” and “phone storage” to one partition.

1 Like

ok, thank you for your explanation.
Then the answer to @Stefan question is definitely no.

So the bug remains, no? :no_mouth:

I’m gonna repeat myself… :slight_smile:

If you don’t like it this way, you have to discuss with the people, who invented Android. :wink:

1 Like