ADB on FP2? [Solved: Uncheck all boxes in USB connection popup]

Just did, unfortunately no difference, still an empty device list.

Then I’m running out of ideas - sorry.

One thing you could try is booting into bootloader mode and checking if you can see the device using “fastboot devices” instead of “adb devices”. If you want to run it as user, you will eventually have to put another rule in.

I added the second udev rule with the google vendor id and booted the phone in fastboot mode by pressing “audio down” plus “power”. I could then see the device and continue booting it:

simon@laptop:~$ fastboot devices
eccfb6fb	fastboot
simon@laptop:~$ fastboot reboot

finished. total time: 0.001s

So it seems that fastboot works, but adb still doesn’t work. :confused: Anybody else any idea? :slight_smile:

1 Like

The adb setting should be stored internally in the data partition. See the second answer in this thread:

Unfortunately, if you can’t get adb access in recovery, you will probably not be able to read the settings table in the data partitions without root permissions. You can install a terminal emulator and try on the device, but I doubt this will actually help.

Anyways, if you can’t access the device via adb although you enabled it I would regard this as a bug and contact the support. Or wait and see if somebody else was successful with this.

Thanks for the link. How can I mount the data/ partition in recovery mode?

btw: In recovery mode I can choose to sideload an apk via adb on the phone and then (but only then!) I actually see the phone:
simon@laptop:~$ adb devices List of devices attached eccfb6fb sideload

So adb is working in recovery? Very well, this means that your setup on the PC is fine and it’s an issue with Fairphone OS not respecting the developer mode / adb settings.

Actually, if you can log into the device via

adb shell

You should be able to do pretty much everything (not as root though) from there. Anyways…I would just do a factory reset and if adb is still broken afterwards then contact the support.


to access adb the best is to disable MTP when connected

1 Like

Yes and no. It only works in recovery while im in the Update from adb menu. Otherwise the phone is not detected (maybe because my laptop got never authorized on the phone). And once im the sideload menu I cannot do much via adb, e.g. it didn’t allow me to run a shell.

I just did a factory reset and retried. Still the same behaviour. So I’ll contact support if nobody has another idea I could try. :confused:

MTP was disabled, it was only mounted as SD card (I have no external SD inserted atm; neither is a SIM card inserted, but this shouldn’t be a problem, is it?)

Have you seen this thread sjjh?

I’m not sure if i understood your problem but i have the problem that my Computer (Linux Mint 13, adb 1.0.31) doesn’t recognize the FP2.
Georg hasn’t a connection problem. Later on he had a problem with rooting the phone. Here his post where he explains how he made it:

ADB was installed by following these instructions:
udev rule set to

SUBSYSTEM==“usb”, ATTR{idVendor}==“2ae5”, MODE=“0666”, GROUP=“plugdev”
(that’s the vendor id i found from lsusb)

That’s what I did:

  1. switched “USB debugging” on (if you have problems finding that option, see end of my post)
  2. plugged cable in, called “adb devices -l” on the kubuntu machine and after a while i got asked to authorize the computer - authorized it.
  3. downloaded the superSu from your link, set udev as said above
  4. renamed the file to
  5. rebooted into recovery
  6. checked - adb devices -l ==> showed the FP
  7. selected the adb-option from the menue on the phone
  8. adb sideload
    8a) --> something gets transferred
    8b) --> kubuntu says Total xfer: 1.02x
    8c) --> F2 says:

Finding update package…
Opening update package…
Verifying update package…
E:failed to verify whole-file signature
E:signature verification failed
Installation aborted.

It also says that it can’t open /dev/block/platform/Msm_sdcc.1/by-name/misc (Permission denied)

  1. I tried once more by uploading the downloaded file (not renamed) and got the same result.
  1. I booted the phone in normal mode again, went to the USB Debug configs, switched OFF the “Verify apps over USB” and tried all again - same result.

By the way - I did not find any option in the configuration menu of the phone to switch on/off USB Debugging and downloaded “USBDebug” from the play store - a separate app, which shows the configuration options all nicely.

Any further wisdom, hints or dreams are welcome :). Cheers,

@neolovich I believe I read through it. Anyway, I think I did everything that he did. What in specific do you mean I should try? :smile:
At the moment I’m failing in step 2:

  1. plugged cable in, called “adb devices -l” on the kubuntu machine and after a while i got asked to authorize the computer - authorized it.

I don’t get asked for authorization and the list of recognised devices stays empty.
I’m happy for any help. :slight_smile:

Do you have ADB 1.0.32?
I just tried it like Georg described it (with ADB 1.0.32) and i have the same problem as you :-/
lsusb shows the FP2 but ADB doesn’t.
So don’t have any hint for you :frowning:


I have a SD- and SIM card so that shouldn’t make a difference.

simon@laptop:~$ adb version Android Debug Bridge version 1.0.31

I just read through which @georgmayer followed.
A couple of remarks:

  1. regarding 3. Update to ADB 1.0.32: "Since Android Lollipop 5.0, ADB 1.0.32 is needed to sideload your device."
    So I might need to update sooner or later anyway, but this is not the problem now.
    And as @georgmayer said he sucessfully used version 1.0.32.
  2. regarding 5. If your device is not detected …: …you may be facing the USB3 bug. On modern computer, most of the USB ports are USB3 and there is an incompatibility between some Android devices and USB3 ports. This problem must be software related, as one of my phone is not recognized thru adb but is fully recognized thru fastboot on the same USB port ! The easiest way to solve it is damn simple : just connect a cheap, self-powered USB hub between your computer and your Android device.
    MyThinkpad Yoga 12 indeed uses USB3. I attached a cheap Saitek PZ37 “MINI UFO HUB” USB HUB to it but it made no difference, the list of recognised devices is still empty.
1 Like

My Laptop hasn’t USB3 :smiley:
So it seems that it is something with the Fairphone OS.

But how/why did @georgmayer it working then? :confused: (If I understood his posts correctly he did, but maybe I misunderstood him and he only managed to sideload an apk, in that mode I can see the FP2 as well in adb :slight_smile: )

Anyway, it might be the right time to contact support, pointing them to this thread (and ask them to forward it to the devs after the holidays). Andy as I should be packing boxes for moving as well right now, I might just step back a little and wait. Nevertheless, if there is anything I can try let me know and I’m happy to do so. I’m just a little out of ideas right now. :frowning:

As @keesj already replied here it’s save to assume the FP team is aware of the thread.

1 Like

So I’ll just patiently wait. :innocent:
So long, happy new year everybody!

@sjjh I had the same problem, could not get adb running. After deactivating MTP, und thus having nothing checked, the USB Access Permission popped up and I am able to access the device with adb…


You’re my personal hero for today! :smiley: MTP was (as said earlier) not enabled. But indeed the check box for “mount SD card” was enabled. Thus I disabled that one as well – leaving me with “having nothing checked” as you said – and now I got the access permission pop-up as well and finally can see the device via adb. So we can close this one as solved (for me).

@neolovich, maybe it’s the same issue for you?


So long story short:
At the popup notification you get when connecting your FP2 to your PC uncheck ALL boxes.

I’ll put the thread to auto-close. If anybody still has problems they’ll have some time to respond. Otherwize ask me to reopen the thread.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.