ADB > error: no devices/emulators found

I was trying to get LineageOS installed on FP2, but I got stuck
(see Project FP2 paused : Project FP2 paused as well).

I started from
From I learnt that I needed ADB + Fastboot. These were already installed on pc (win7).

The command

adb devices

does not return a device.
Amongst others, the command

adb shell

returns ‘error: no devices/emulators found’.

I did enable USB debugging.

Although FP2 is connected to pc, windows explorer (WE) does not show a FP2 node
(when connecting my nokialumia I’m used to seeing a node for it in WE).

I don’t know it this is related to the somewhat instable FP2 (FP Open OS ).

How can I make sure ADB recognizes the FP2 when connected to pc (through usb)?


PS. Somewhere along the way I somehow got the TWRP-screen on FP2. At that point I was called away and when I returned the screen was gone, FP2 switched off.

This is normal. You should see the phone in Explorer once you select MTP as the USB connection mode instead of Charging (which is the default for security reasons) on the phone. There should be a notification to tap to get to this choice.

As for the adb command … can you boot into #dic:fastboot mode with the phone connected to the PC and check whether the command fastboot devices finds your phone?
This should show whether the connection isn’t there or whether ADB needs further investigating in Windows.

1 Like

Thanx @AnotherElk,
I can’t recall having seen a notification on FP2 asking which usb-mode to use, when connecting FP2 to pc.

Coming days I may try the #dic:fastboot mode. Should I enter that command in cmd-box on pc then?

If there’s no notification then the reasons can be

  1. that you aren’t using a USB data cable
  2. that your phone is not unlocked when you looked for the notification (it’s not visible on the lock-screen)
  3. that it’s related to your instable FP2

This is why you should try to use the fastboot mode of the phone as mentioned by @AnotherElk. Then 2. and 3. can not cause issues.

Yes. You may even try to start the cmd-box as “Administrator”. This might be necessary.

1 Like


Today I gave it another try, but no luck ( start to be like work a bit :expressionless: ).
I did learn that #dic:fastboot is the link to the fastboot entry in the dictionary, here on this forum. :slight_smile: .

I did reset FP2 to factory settings.
In FP2 settings I set USB debugging on an USB transfer mode to MTP.
I opened several dos-boxes, as Admin.
And I did manage to reboot with fastboot.

On windows pc, in device manager, under ‘other devices’ node, I see one node ‘FP2’.
This node’s icon has a yellow triangle with an exclamation mark in it.
Under properties I see that no driver for this device is installed (Dutch “De stuurprogramma’s voor dit apparaat zijn niet geïnstalleerd. (Code 28)”).

On this page,, a driver is mentioned, I think. But can no longer be found.
Installing " Samsung official Android USB Driver (15.3 MB)", for manual installation, does not help. When I chose the option to update driver in device manager and I pointed to the directory of the samsung driver(s) it said it can’t find a driver for this (FP2) device.

Maybe later on I will have another try ( connecting FP2 to pc, to finally install LineageOS ).

This here was done because MTP didn’t work when TWRP was booted, but it could serve as a generic driver repair … (ignore the TWRP part and just boot the phone) …

1 Like

So, several hours down the line again,
again no luck.

Pc and fp2 have been rebooted several the times the later in recovery as well as #dic:fastboot mode (also know as #dic:bootloader mode!).
Tried not to forget to check whether fp2 was in usb-debugging mode and that usb-mode was mtp. In case I forgot, went back and tried same step with these options properly set.
On pc wiped all programs that had adb.exe and/or fastboot.exe.
Downloaded latest Android SDK platform tools.
Installed twrp.img (twrp-3.3.1-1-FP2.img) again.
In the properties of I removed some security blocking
( in Dutch “Dit bestand is afkomstig van een andere computer en wordt mogelijke geblokkeerd om deze computer beter te beveiligen”, so it was blocked to since it came from other computer for security’s sake of my pc ).

The repeated result was error:21.

Finding update package…
Opening update package…
Verifying update package…
E: failed to verify whole-file signature
Update package verification took 39.4 s (result 1)
E: Signature verification failed
E: error: 21
Restarting adbd…
Installation aborted.

What was the exact command you ran to get this output?

For some quick tries to fix it

  • make sure Signature verification is disabled in TWRP’s settings.
  • redownload the file and try again (I’ll assume you wanted to adb sideload the LineageOS ZIP file to TWRP in ADB Sideload mode).

I didn’t even know something like this was in file properties, I never touched that. I wouldn’t change that if nothing forced me to.

1 Like

The command I used was :
adb sideload C:\temp\

On FP2, recovery (right?) mode the screen looks like this:
{yellow text on a black background}
Android Recovery Fairphone/FP2/FP2 7.1.2/19.11.2/sibon-24df0be9 userdebug/release-keys Use volume up/down and power.
{/yellow text on a black background}
{blue text on a black background}
Reboot system now
Reboot to bootloader
Apply update from ADB
Apply update from SD card
Wipe data/factory reset
Wipe cache partition
Mount /system
View recovery logs
Run graphics test
Power off
{/blue text on a black background}

Is that where I disable Signature verification in TWRP’s settings?

Redownloading is possible, I’ll try that.

My wish to have a working FP2 compelled me to change that setting.
Now I know it has no effect I won’t do that with the newly downloaded file.

Will report back, …woensdag?

What you describe is the stock Android recovery, not TWRP (see here for some TWRP screenshots).

You could try that again. Make sure after installing TWRP to directly boot into TWRP to let it make itself resident. If you boot Fairphone Open OS inbetween, it may replace the new TWRP with its own recovery again.
In this is point 6 in “Installing a custom recovery using fastboot”. Don’t miss it.

1 Like

‘de aanhouder wint’ !

Step 6 was indeed crucial, but it wasn’t clear how exactly.
At the third bullet of step 3 in this explanation though, I found out how to do it:

  1. “Keep the Volume+ key of the Fairphone 2 pressed”
    W H I L E
  2. On the computer: fastboot reboot (with the key << still >> pressed)

That part and how these two section relate to each other could be uptaded in the wiki:

This weekend I’ll insert sim and sd cards.

Thanx a lot @AnotherElk :+1:t4:


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.