A never-ending repair story (USB connector FP1)

I have news on the matter!

Yesterday I went to pick up my phone, after last week the issue was not solved after the second attempt and they said they will try it a third time. (I tried to pick up the phone on Friday, but they were in the middle of a flee market and didn’t have my FP at the shop, when I came there…)

Long story short, the USB connector is not loose anymore (at least for now)! :smiley: They told me that they could sand the junctions of the USB connector on the motherboard and were then able to solder in a new generic Samsung USB connector.

I’m confident again that my phone will work until January 2018. :slight_smile:


That’s good news. Fingers crossed for you

1 Like

But to be honest: Since I’ve a work phone where most of the time the calls are in HD voice I don’t like anymore to call with my FP1. The quality is too bad… A pity they deactivated hd voice on the modem firmware because of troubles with T-Mobile…

According to your other post it was T-Mobile. That’s kind of ironic, in my opinion. :wink:

Anyway, calling still works fine for me, just in loud environments it’s sometimes too low (I’m with A1 (Vodafone in Austria).

Thanks, edited…


Maybe they wanted to make up for it by selling the FP2 in shops here in Austria… :grin:

Oh, That sounds good. Good luck for you with it. Maybe also consider purchasing a magnetic charging cable. There are several also slim but practical types out there and most of them at reasonable price imo.

Can you recommend one? I have found these in a quick search: http://www.magneticchargingcable.com/

I doubt however, that I’d be able to plug in my headphones when the adapter is in the USB port. USB and headphones connectors are quite close, as you can see in the following iFixit picture:

Oh, erm - well yes. I did not know the mechanical design of FP1. I think in this case it is not so easy finding one which will be slim enough. I backed some at kickstarter and indigogo (Mµconnect & ZNAPS) not having my hands on them yet. Also I found this at a electronic dealer named “Reichelt”

Most probably Conrad also offers similar accessories. You could take a glance into the datasheet for the dimensions hopefully finding one that matches with your phone…well the alignment really is very unluky…

1 Like

I just figured out that the repair shop failed to connect the data pins of the new USB connector… So when I connect it to my computer now, it is not detected. For adb I used this guide to enable Wireless ADB (in conjunction with adbWireless from F-Droid). If I want to transfer files, I will have to make use of this solution:

1 Like

Amaze File Manager includes a FTP server now, you don’t need another app for that, :wink:

Should you have any doubt about how to do something, contact me: I lived quite a long time with a Nexus 4 with the same problem (non-working data pins), working as an Android developer myself, :joy:


I should update Amaze then…! :grin: And rewrite the wiki…

1 Like

I think that my proximity sensor also got roasted during the repair. SatStat doesn’t display any output in the field distance (cm), before it was either 0 or 1. Now the screen doesn’t turn dark, when I do a call. I will have to use my power button from now on to turn off the screen during a call… :confused:

Hi…i am a new user here. As you was told a new generic usb connector did not fit the place where it should, hence to this it was generic not FP specific. Probably they have no original FP1 usb connector at hand. Using the old one may work if it´s not completely broken, but of course when the main pcb is broken there you seem to be out of options. With this knowledge that it may have been not properly mounted at production you may get back to FP and try to agree on a discount on a new FP2.

Here you can find two alternative magnetic USB cables:

1 Like

A new chapter in this story: 9 months later the USB connector got loose again, but they agreed to resolder it under warranty. (They have a 1-year-warranty on repairs policy.) Still hoping to reach Jan 2018 with this phone! :wink:


I’m in the same situation, :cry: my FP1 cannot charge, it is able only when I put the cable in some, strange, position… but I hope that I’ll be luckly :sweat_smile: and I can fix it with soldering the usb connectors or cleaning the connector with alchool isopropylic.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.