A-GPS not working (v1.8)

[see this article][1][quote]The built-in EPO updater of the Fairphone (or other Mediatek phones) downloads the two EPO.dat and the checksum from an FTP server from Mediatek. However, the checksum is often calculated wrong by Mediatek[/quote]
[1]: https://gitlab.com/sn0b/fp1-epo-autoupdate/wikis/home

Thanks for explaining. If the EPO checksum isn’t calculated properly, why is nobody reporting this to Mediatek and is fixing the bug?

Why do you think nobody reported this to Mediatek?
Mediatek decides which bug gets priority and which bug not.

Okay. Two more questions: do I have to enable data connection to make GPS work? Or will it work with WiFi only?

GPS works with nothing at all if need be. What is at stake with ‘Assisted GPS’ is faster convergence.
A-GPS uses extra info which is the identity of neighboring wifi network names and GSM towers ID; this is what gives you the initial large location dot at startup (until enough GPS sats are catched).
How this extra info is fetched depends on what you allow: for EPO data, for instance, FP1-EPO Autoupdate will go fetching it only when on wifi, in order not to overspend. You also can cancel this and manually update every now and then, which basically should be as efficient.
But even without any data connection, you GPS will converge. Only, verrry slowly. Honestly, not fast enough to take the phone out in some street and know where you are (or else, find a square and wait :slight_smile: )

@Lidwien , The EPO download is now simply disabled and if you enable it in the settings there is no need to install FP1-EPO Autoupdate. We disabled EPO download because test showed that when this was enabled the time to first fix was about 45 seconds (in the open).

We also tested with AGPS “only” and with WIFI disabled (Here is a ratter bad quality video shot this morning http://dev.fairphone-open.com/keesj/up/AGPS_morning_test.mov )

@michaelheuberger there are a few things at hand

First of all if you use a GPS without any form of assistance getting a fix can take up to 12 minutes (the data about the exact location of the satellites is sent over the GPS signal and this can take up to 12 minutes).

EPO Download and AGPS (satellite data) downloads can be done over a data connection and over WIFI. But there is a big difference between EPO data and AGPS data. EPO data is valid for about 20+ days while the AGPS data only for something like 4 hours.

Testing showed that getting a first fix using EPO data is slow(± 45 seconds) compared to getting the fix over AGPS(± 15 seconds).

There is a lot of confusion about location data. AGPS can also directly provide the device with information about it’s current location. This is normally a global position that is not very accurate and it depends on the network what kind of data you get back (Wifi or 3G). This kind of positioning will at least provide a global location even when inside a house.

In my experience enabling the data connection and enabling APGS provides a decent (not great) positioning but when in a location where I have no connectivity I will enable EPO download beforehand.

keesj’s post describes my own gps experiences perfectly. When I first got my FP, I noticed that the only thing that actually worked better on my old and outdated HPC was the GPS function. I often had to wait 1-2 minutes for a fix, sometimes more (but never as much as 12 minutes, thankfully).
I do not use the GPS particularly often, but a fortnight ago (when still running the 1.6 version) I sat in my car and needed to find an address. I was surprised and delighted to find that the fix took no more than 15 seconds or so, and after a few more tests (also after updating to 1.8) it still works just as well.
I have A-GPS enabled, and also valid EPO data files installed using the invaluable FP1-EPO installation app mentioned above.

Height curves, covered distance, and walking/running speed registered by apps of the ‘My Tracks’ type is another thing, though. These data are seldom accurate. But I’m not sure whether FP hardware or software can be blamed for this or if it is simply a consequence of the limitations of the GPS technology. And personally I don’t care at all.

Are you suggesting that the following issue is solved?[quote=“Lidwien, post:10, topic:3382”]
The built-in EPO updater of the Fairphone (or other Mediatek phones) downloads the two EPO.dat and the checksum from an FTP server from Mediatek. However, the checksum is often calculated wrong by Mediatek

Because that’s the reason I use the Epo autoupdate from Fdroid.
For me a AGPS data which is only for something like 4 hours is not long enough.
That’s why I like the EPO data from Fdroid, which is valid for about 20+ days and I can update just at home using the WiFi.

1 Like

Yes, the download URL was moved from FTP to HTTP and it now is possible to download the EPO files without the additional software. You can go into settings->location access->Click GPS satellites and enable GPS EPO assistance.


To be clear about EPO: is EPO enabled slower because it couldn’t download recent EPO data from MediaTek or is it slow even when you’re up-to-date?

@Jerry: As I understand it, yes. EPO data files means that your phone don’t need to get all information from scratch on the slow gps connection, but a-GPS helps to get more information about your present location faster (over 3G). a-GPS is explained in detail here: http://en.wikipedia.org/wiki/Assisted_GPS
As keesj wrote above: getting a positon from scratch can take time, even up to 10-12 minutes. With fresh EPO files stored, less than a minute. With a-GPS, 15 seconds or so.
That’s my experience as well. I can run a speedview app in my car without data connection turned on, and with EPO files I get a fix in a minute or so. With data enabled it’s noticeerably faster.

1 Like

Ah, thanks for explaining guys. Since the download URL was moved, I assume the FP1-EPO Autoupdate is not needed anymore then. So I uninstalled the FP1-EPO Autoupdate and have GPS EPO assistance re-enabled then.

But I still do not get a GPS fix, even after 20 minutes. These are my settings:

  • Fairphone FP1 on v1.8
  • WiFi disabled
  • Data connection enabled
  • GPS EPO assistance on with autodownload
  • A-GPS on with the Network request option on and for the Network used option I selected the home network only.

I spotted this warning in the A-GPS settings under MOBILE NETWORK which says

SIM1 is Active
A-GPS needs to access the mobile network via data connections

Huh? I do not understand this warning. I have WiFi disabled and data connection enabled, so mobile network should be accessible. Any clues?

If you disable your WiFi, you can’t connect to your home network.
As you selected the A-GPS to work only with your home network, you never will get an GPS-fix.

Oh, do I have to select home and roaming network both under A-GPS?

@Lidwien I don’t think home network refers to a WiFi network but to the network of your 3G provider.

@michaelheuberger I get the same message as you so I assume it doesn’t mean anything is wrong. Try disabling EPO and see if you get a fix then.

My settings, that practically always gives a fix within 15 seconds, are:
EPO assistance enabled
EPO auto download disabled (on principle I always disable autodownloads)
A-GPS enabled
in A-GPS settings, all boxes are unticked except ‘Network Request’.
I get the same message at the bottom as mentioned by @michaelheuberger, but I read this as information, not as a warning.

Maybe an impertinent question, but: you are outdoor when testing, right? Getting a fix indoors can take ages or fail completely. On the other hand, one seldom needs GPS navigation when inside a building…
Cars can be tricky, too. Preferably your phone should be mounted close to the windscreen.

And yes, I share @Jerry’s belief: 'Home network* can be your wifi or your provider’s mobile data network. If you choose ‘only under home network’, I gues that a-gps will not work when roaming.

@Jerry [quote] I don’t think home network refers to a WiFi network but to the network of your 3G provider.[/quote]

Oh, you could be right. Sorry for my mistake.

You must first download and install Fdroid on your Fairphone.
Then on your Fairphone you go to the app Fdroid and in the app search for FP1-EPO Autoupdate.
On the link you can find more information how to install.

As keesj indiciated in an earlier post, switching from ftp to http for the EPO data server might mean that the FP1 EPO download app is no longer necessary.
I tried the inbuilt download function (in the location settings/EPO settings menu) today, and data files updated instantly, something that has never happened earlier.
I won’t uninstall the extra downloader app yet, though…