4G disable with two sim cards

When I have only one sim card, it works with 4G.
When I have two sim cards, it works with edge and I can’t select 4G.

1 Like


What do you mean by that? As I don’t understand that phrase, I’m not sure what your problem is. Anyway, I know that with two SIM cards it’s not possible to have both in 4G (or 3G) mode. At least one of them must be in 2G mode. For more information about that, please search the forum, it has been mentioned and discussed a few times, I guess.

Same here, I have two sim card, one for phone / mms and the other for data only in 4G.

If I only put the 4G sim card, it works. If I put the two sim card, the 4G switch to Edge only and I can’t have 4G anymore on this sim.

Edit: it work with [quote=“tofra, post:3, topic:12241”]
The setting is in the data usage monitor and in the SIM card settings. Well, you have to set SIM1 to 2G only and SIM2 to 4G to have fast data speed. It’s in the settings at “More…” - “mobile networks”.