1 month without reply from Support [solved]

I have had an open support issue which Support has not replied to in one month. I don’t feel that this is ok, but I’m not sure what to do. Suggestions?

Call them. That usually works wonders.

1 Like

Can confirm that. They are also pretty nice on the phone, in fact I just had to call them to get things with my return package sorted out, it was a nice talk.

1 Like

I did call them the same day as my last post ant they told me that they would get back to me as soon as they had any info about my issue. That was 24 days ago.

And now they seem to have removed the option to view your own questions to support in your account, so I don’t know the number of my support issue anymore!

May I ask what your request is?

Do you mean the request number?

No the content. What were you asking them?

My headset mic suddenly stopped working (Kingston HyperX II Cloud). It’s functional for 3 seconds but then shots down, which means that when I answer a call the caller can hear me say Hello and then nothing… I got a top module replacement but it didn’t help. I did some troubleshooting of course, tried other headsets, my Kingston on other phones etc.

The headset mic has btw always been an issue on my phone but it was working with my Kingston headset, until two months ago. For example, I have a Röde Smartlav lavalier mic that I use when producing videos, like interviews. It’s compatible with Android and iPhones but not Fairphone for some reason. When I workout I have a pair of Polk Audio Ultrafit 3000. Same problem there, the mic not working.

They now claim that my headset is not compatible with FP2, eventhough I have told them that it has been working before!

Also, the mic is working when recording with a sound recording app but not when recieving phonecalls!


My name is Michiel, I’m the support manager at Fairphone. I’m sorry to hear of your issues! We have been a bit in limbo with your support request, since it is hard for us to pinpoint what the exact issue is. The replacement of the top module obviously didn’t help, so we want to rule out the possibility of a software issue by asking you to reset the phone.

So if you can move forward with this, we would appreciate it. If this does not help, we can troubleshoot further. Please make sure to make a back up first!

And, our apologies for the long wait, that shouldn’t have happened.


@anon48893843, I am happy to tell you that the headset seems to be working again without a hard reset. I don’t know what solved it, maybe wiping the caches or a simple reboot?

I have made perhaps 10-15 calls without problem.


Hey, that’s pretty awesome! Thanks for updating me. Might you encounter more (or other) issues, make sure to let me know.